Sign in with
Sign up | Sign in
Your question

Malfunctioning USB ports?

Last response: in Motherboards
Share
July 21, 2010 2:02:16 AM

Hello all,

I am having a strange problem. Lately I have had devices that are plugged into USB ports just stop working, and Windows 7 reports that it is now an unknown device and that the drivers have not been installed properly. This has happened to my keyboard several times, my Ambx setup once, my 360 controller and other devices.
Usually, unplugging and replugging them in fixes the issue, though sometimes I have to switch ports.

I hope this isn't a mobo issue but I thought I would get your input.

What do you think?
July 21, 2010 3:41:15 AM

avalanche0316 said:
Hello all,

I am having a strange problem. Lately I have had devices that are plugged into USB ports just stop working, and Windows 7 reports that it is now an unknown device and that the drivers have not been installed properly. This has happened to my keyboard several times, my Ambx setup once, my 360 controller and other devices.
Usually, unplugging and replugging them in fixes the issue, though sometimes I have to switch ports.

I hope this isn't a mobo issue but I thought I would get your input.

What do you think?



Try Seeing if any other Devices Work that use USB borrow one from a friend and see if you have the same problem. Check IT Diagnostics software does loopback testing on USB ports. If you have USB 2.0 it gives you a good excuse to buy a USB 3.0 PCI-E add-on board and get the latest USB spec I think it costs 50-60 bucks Via makes it!
m
0
l
!