Sign in with
Sign up | Sign in
Your question
Solved

Graphics Problem with my BFG 9600GT OC

Last response: in Graphics & Displays
Share
December 29, 2009 3:38:03 AM

Im having an issue where the graphics will get really messed up. Images, colors, everything goes white or changes or gets all screwed up. Happens about an hour or two into gameing, anyone have any idea whats going on?

550w PSU

athlon 64 x2 4400+

BFG 9600gt OC

a8n-sli Deluxe mobo

Best solution

December 29, 2009 3:57:58 AM

Heat problems. Try EVGA Precision, manually raise the fan speed to 85% prior to gaming, then play for an hour or two and see if the problems persist. If they go away, it was a heat issue.
Share
a b Î Nvidia
December 29, 2009 5:14:15 AM

Also make sure you have the latest VGA driver installed too
m
0
l
Related resources
December 29, 2009 9:24:12 AM

those artifacts are probably due to ur GPU heating up .. check out your fan and see if it works properly, or increase your fan speed using nTune though be careful not to screw up ur fan bearings
m
0
l
December 29, 2009 1:41:36 PM

Thanks for your help guys, ill try that EVGA Precision. Will it still work even tho i have a BFG card? Maziar what exactly is a VGA Driver? The video card driver? Got that updated to latest on nvidia site.
m
0
l
December 29, 2009 2:00:48 PM

fel2941 said:
Im having an issue where the graphics will get really messed up. Images, colors, everything goes white or changes or gets all screwed up. Happens about an hour or two into gameing, anyone have any idea whats going on?

550w PSU

athlon 64 x2 4400+

BFG 9600gt OC

a8n-sli Deluxe mobo



Hmmm,Heat problems,,had a similar experience with my 8800gt,don't remember the layout of the 9600,but the 8800 had an active fan on the gpu,, and a passive radiator over the power circuitry which had a wad of oem thermal paste , which over time the components worked ther way through,causing similar problems,so I cleaned it off and replaced it with 'old reliable' AC5,so the next time [??] your system goes off the path ,, physically check the video card manually for excessive heat,,then decide what needs to be done...:) 
m
0
l
December 29, 2009 2:07:01 PM

The EVGA Precision does work, heh. Its idleing at 47/48c at 35% fan speed and i jacked the fan up to 50% and its lowered to 43c.

Im not sure exactly what your talking about dokk2 :o 
m
0
l
December 29, 2009 2:54:01 PM

fel2941 said:
The EVGA Precision does work, heh. Its idleing at 47/48c at 35% fan speed and i jacked the fan up to 50% and its lowered to 43c.

Im not sure exactly what your talking about dokk2 :o 


dokk2 is talking about disassembling your videocard, cleaning off the old thermal paste, applying a new coat of thermal paste Artic Silver 5, and then putting it all back together. You might never need to do that but if you play hours everyday, maybe in one year or two, you will need to do it and also blow out the fan housing of dust.
m
0
l
December 30, 2009 1:03:07 PM

Well, it seemed to be a heat issue. Whole day and haven't had anything similar happen, thanks for the help guys!
m
0
l
!