Sign in with
Sign up | Sign in
Your question

SP2 and FTP Servers

Last response: in Windows XP
Share
October 2, 2004 3:17:32 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.security_admin (More info?)

Hi,

I'm having troubles connecting to FTP servers since the install of SP2 on
my xppro. Can someone tell me which ports sp2 is closing? Or where should I
be looking?

TIA

Ana

More about : sp2 ftp servers

Anonymous
October 2, 2004 3:17:33 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.security_admin (More info?)

Perhaps the troubleshooting information in this article may help:

You may not be able to open a project when you try to connect to a remote Windows XP
Service Pack 2-based computer by using the AutoCAD FTP service
http://support.microsoft.com/default.aspx?scid=kb;en-us;873185&Product=windowsxpsp2

Here's how to correct the problem after opening Port 21 via the
SP2 firewall Exceptions tab:

1. Open Internet Explorer >Tools > Internet Options > Advanced tab

2. Uncheck the box: "Use passive FTP (for firewall & DSL modem capability)

--
Carey Frisch
Microsoft MVP
Windows XP - Shell/User

Be Smart! Protect Your PC!
http://www.microsoft.com/athome/security/protect/defaul...

----------------------------------------------------------------------------------

"Ana" wrote:

| Hi,
|
| I'm having troubles connecting to FTP servers since the install of SP2 on
| my xppro. Can someone tell me which ports sp2 is closing? Or where should I
| be looking?
|
| TIA
|
| Ana
Anonymous
October 2, 2004 10:37:02 AM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.security_admin (More info?)

Hello Carey,

RFC 3232 is the assigned port numbers RFC standard.
You can search the database for other rfc's.

It is Port 20 and 21 for ftp.
ftp can use both tcp and udp ports 20 & 21.
port 20 is data.
port 21 is control.
You need both!
The Passive ftp command in internet explorer is for "Allowing communication"
through some firewalls and or proxies.

I am currently havaing the same issue after installing sp2.
Windows xp professional with sp2.

http://www.rfc-editor.org/cgi-bin/rfcsearch.pl?searchwo...

I have tried excluding the ftp.exe for Windows/"DOS" in the firewall.
Which windows states that you can choose the application
and it will open all ports the app uses, it still does not work.
(ftp, Does not function or work)

Opened up all traffic to the IP Address of the FTP server.
(ftp, Does not function)

I know its the firewall because when you turn it off, everything works fine,
ftp through the command line and through Internet Explorer.

I have followed all of the suggested fix's, it still does not function!!
You may wish to look at this document.

http://support.microsoft.com/default.aspx?scid=fh;EN-US;windowsxpsp2

Some programs seem to stop working after you install Windows XP Service Pack
2
http://support.microsoft.com/default.aspx?scid=kb;en-us;842242
There are other documents on technet as well, some redundant information.

I am waiting to get the offical response from Microsoft.
You probably should put in an offical complaint or request.


"Carey Frisch [MVP]" wrote:

> Perhaps the troubleshooting information in this article may help:
>
> You may not be able to open a project when you try to connect to a remote Windows XP
> Service Pack 2-based computer by using the AutoCAD FTP service
> http://support.microsoft.com/default.aspx?scid=kb;en-us;873185&Product=windowsxpsp2
>
> Here's how to correct the problem after opening Port 21 via the
> SP2 firewall Exceptions tab:
>
> 1. Open Internet Explorer >Tools > Internet Options > Advanced tab
>
> 2. Uncheck the box: "Use passive FTP (for firewall & DSL modem capability)
>
> --
> Carey Frisch
> Microsoft MVP
> Windows XP - Shell/User
>
> Be Smart! Protect Your PC!
> http://www.microsoft.com/athome/security/protect/defaul...
>
> ----------------------------------------------------------------------------------
>
> "Ana" wrote:
>
> | Hi,
> |
> | I'm having troubles connecting to FTP servers since the install of SP2 on
> | my xppro. Can someone tell me which ports sp2 is closing? Or where should I
> | be looking?
> |
> | TIA
> |
> | Ana
>
>
Anonymous
October 29, 2004 5:01:10 PM

Archived from groups: microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.network_web,microsoft.public.windowsxp.security_admin (More info?)

Agreed, something within the Firewall continues to stop ftp even after adding
the exceptions (ports 20 and 21) within the Firewall. I also turned off the
passive-mode within IE just on the off chance it was somehow related to that,
even though I'm trying to ftp from another application, but still no
connection. It works fine when I turn off the Firewall, so it has to be that
which is doing it. My only choice to effectively get work done right now is
to turn off the Firewall, and that's just stupid, why go to all the effort to
beef up the Firewall when it breaks a basic service like ftp?

"xp ftp" wrote:

> Hello Carey,
>
> RFC 3232 is the assigned port numbers RFC standard.
> You can search the database for other rfc's.
>
> It is Port 20 and 21 for ftp.
> ftp can use both tcp and udp ports 20 & 21.
> port 20 is data.
> port 21 is control.
> You need both!
> The Passive ftp command in internet explorer is for "Allowing communication"
> through some firewalls and or proxies.
>
> I am currently havaing the same issue after installing sp2.
> Windows xp professional with sp2.
>
> http://www.rfc-editor.org/cgi-bin/rfcsearch.pl?searchwo...
>
> I have tried excluding the ftp.exe for Windows/"DOS" in the firewall.
> Which windows states that you can choose the application
> and it will open all ports the app uses, it still does not work.
> (ftp, Does not function or work)
>
> Opened up all traffic to the IP Address of the FTP server.
> (ftp, Does not function)
>
> I know its the firewall because when you turn it off, everything works fine,
> ftp through the command line and through Internet Explorer.
>
> I have followed all of the suggested fix's, it still does not function!!
> You may wish to look at this document.
>
> http://support.microsoft.com/default.aspx?scid=fh;EN-US;windowsxpsp2
>
> Some programs seem to stop working after you install Windows XP Service Pack
> 2
> http://support.microsoft.com/default.aspx?scid=kb;en-us;842242
> There are other documents on technet as well, some redundant information.
>
> I am waiting to get the offical response from Microsoft.
> You probably should put in an offical complaint or request.
>
>
> "Carey Frisch [MVP]" wrote:
>
> > Perhaps the troubleshooting information in this article may help:
> >
> > You may not be able to open a project when you try to connect to a remote Windows XP
> > Service Pack 2-based computer by using the AutoCAD FTP service
> > http://support.microsoft.com/default.aspx?scid=kb;en-us;873185&Product=windowsxpsp2
> >
> > Here's how to correct the problem after opening Port 21 via the
> > SP2 firewall Exceptions tab:
> >
> > 1. Open Internet Explorer >Tools > Internet Options > Advanced tab
> >
> > 2. Uncheck the box: "Use passive FTP (for firewall & DSL modem capability)
> >
> > --
> > Carey Frisch
> > Microsoft MVP
> > Windows XP - Shell/User
> >
> > Be Smart! Protect Your PC!
> > http://www.microsoft.com/athome/security/protect/defaul...
> >
> > ----------------------------------------------------------------------------------
> >
> > "Ana" wrote:
> >
> > | Hi,
> > |
> > | I'm having troubles connecting to FTP servers since the install of SP2 on
> > | my xppro. Can someone tell me which ports sp2 is closing? Or where should I
> > | be looking?
> > |
> > | TIA
> > |
> > | Ana
> >
> >
!