Sign in with
Sign up | Sign in
Your question

GPT USB 1TB hard drive not being assigned drive letter

Last response: in Storage
Share
December 17, 2011 4:21:26 AM

Hi.
I have been given a USB 1TB Hard drive to work on that has just failed.
The Drive is a western digital Elements 1023 1TB. Externally powered.
The drive was formatted under Mac OX 10.5. It has been partitioned into 2 * 465 GPT partitions, plus the protective MBR partition (apparently FAT32.. Strange... maybe because it was formatted on a Mac??).
The drive stopped working on the Mac after it was brought on an international flight from France to Vietnam, where I am.
First thoughts: physical failure. But the drive has not been bumped or dropped, and surface scans and integrity checks reveal that the drive is healthy. It sounds to be running smooth and quiet.
The computer being used to analyze and fix the drive is running Windows 7 X64. It recognized and installed the hard drive immediately.
However, the drive does not appear in explorer and is not assigned a drive letter.
The drive does however appear to be functioning normally and is visible under device manager.
I am unable to assign a drive letter using Disk manager (greyed out) or EASEUS partition manager.
Formatting is not an option because this is the only copy of the essential data that was brought over. EASEUS lists the GPT partition types as "other".
So where do I go from here? The drive appears to be healthy, and I suspect the issue is to do with Windows recognizing the GPT file partitions. The thing to squish that though is that it stopped working on the Mac also.
I'm not familiar with macs so in addition to advice on where to go from here, I'd like to know about any possible issues I may experience trying to fix a Mac formatted 1TB USB HDD with GPT partitioning under Windows 7 x64.
I'm thinking maybe try find some software that scans and analyzes the GUID file table? Thoughts?

Update: I've just run Testdisk and it finds no problem with the file structure.. I think. It detects the GUID file system and says all partitions are healthy. Is this simply an issue of trying to plug a mac hard drive into a windows computer and the users who gave me the hard drive have a problem with their computer? Should I be able to access this hard drive on this computer?

Update 2: Testdisk lists the Gpt partitions as type MAC HFS+ and it appears windows 7 cannot read this by default?! So I guess now what I need is Windows 7 software that allows me to mount and analyze a MAC HFS+ hard drive?! Is that correct?

Thanks for your help.
December 17, 2011 12:07:11 PM

Update 3: Okay so loading a HFS+ file system program allows the hard drive to mount and everything seems intact but it still doesn't work when taken back to the owner an tested on their setups. Tested on both a Vista laptop and a new mac (both perfectly working and tested with other hardware), the exact same hard drive (with cable etc..) doesn't even get detected as being connected to a USB port. Now I think the problem has to do with inconsistent voltage levels being fed to the Hard drive by the power adapter, causing the hard drive to not initialize properly. Anyone have any experience in this? It's the only difference I can think of that would cause the hard drive to perform differently in two different locations. I don't have a voltmeter on hand.
m
0
l
December 17, 2011 9:09:42 PM

I would get an UPS if I were you. I wouldn't want to leave my hardware at the mercy of power lines in Eastern Asia. Maybe they have awesome power lines over there and I just don't know it, but I would have the UPS if it were me.

In any event, you can't expect windows to willingly play ball with Mac. Microsoft doesn't support anything that isn't Microsoft. MS isn't like Ubuntu where it supports everything under the sun right out of the box.

You should consider trying to load a mac OS somehow or trying to get your hands on a mac computer for testing purposes that is different than the one it doesn't work on, preferably also one that is on an UPS.
m
0
l
Related resources
December 18, 2011 3:21:05 AM

We have voltage stabilizers in our houses here. At least my house and all previous houses do.
Yup agreed that Windows and Mac are not easily compatible, but I'm past that point now. I was able to get the hard drive to work perfectly on my Windows 7 x64 machine, but it still doesn't work on the new mac, or on an x32 vista machine, both of which work perfectly otherwise. Suggestions?
m
0
l
December 25, 2011 12:33:48 AM

Well the issue was to do with voltage. So there you go, an unstablized power supply can result in externally powered hard drives to not initialize properly. Hope this helps someone out there.
m
0
l
!