Sign in with
Sign up | Sign in
Your question

4th Master Hard Disk Error

Last response: in Storage
Share
December 17, 2011 9:43:24 PM

I have a DVR hard drive in my computer at home (500 GB Seagate) that somebody pulled out of their DVR when they got a 1 TB version and they sold it to me on ebay for like $10.

I have been using the thing as a data drive and it has worked pretty well for a $10 drive.

My PC is dual boot with Ubuntu and Windows 7 (previously Ubuntu + XP) and in my current and old configuration I got the error:

4th Master Hard Disk Error

every time I started the computer. In the BIOS, I set it not to require me to press F1 when this happens so I don't get annoyed much by this every time or anything.

However, if I cold boot into Windows, it won't recognize the drive.

If I cold boot into Ubuntu it will recognize the drive. If I restart from there and go to Windows 7 then Windows will recognize the drive.

If I cold boot into Windows (fail) then restart into Ubuntu (success) and again restart into Windows (success) the drive will recognize.

If I cold boot into Ubuntu (success) then restart into Windows (success) then restart again into Windows (success) it will recognize the drive.

No matter how I slice it, Ubuntu has to have been previously loaded for the drive to ever work in Windows. Without Ubuntu it will never work.

Linux is very fault tolerant and I think this probably has a lot to do with it.

I don't restart my computer very often, so this problem is more of a pride thing than anything to me.

If I can get rid of the error so that I can cold boot into Windows and it will work, that would be great.

Even though it is a data drive and I have quite a lot of data on it, I have a lot of tolerance to do things like ripping the 300 gigs of data off of it, formatting it, and sticking the data back on, even though it takes like a RL day to accomplish that gargantuan task.

I recently formatted the drive from within Ubuntu as a regular fat 32 drive and the error remains.

I don't suppose that any amount of formatting will ever really make this problem go away, though. Unless I have some realistic hope of getting rid of the error by formatting it then I would rather not sit there and do it over and over again.

Anyway, I realize this is a DVR drive and was never intended to be doing what it is doing, but at the same time I think that it is potentially possible that the drive should work with no errors too by some gizmo wizardry or other.

If anyone has a thing they think I can do that has a realistic hope of fixing it, feel free to spit it out.

I am travelling currently so I will have to try some of the suggestions when I get back from that, but I would kinda like to start the brainstorming now if people wouldn't mind.

I do pretty well with computer hardware and there are very few problems I have come across that I haven't been able to solve, so anything people can come up with I can probably accomplish pretty well with limited instructions and I know whether most things have a hope of working before I try them so keep that in mind if I am skeptical about some method or other.

Anyway, I am pretty sure that the 4th Master thing comes from the fact that I have two (unused) IDE slots, a regular Seagate 500GB (Sata 0), and the DVR hard drive (Sata 1) in my configuration. That seems to be where the 4th Master thing is coming from.

The DVR drive itself is just a regular Fat 32 drive, no boot records or anything like that. It has one volume that encompasses the entire capacity. Regardless if I format the drive in Ubuntu or Windows the symptoms of the problem don't change.

I can't really think of much else that may apply here, but if I do I will throw it out there asap. My system setup isn't very applicable as far as I can tell, but it is in my signature regardless. Nothing was different from when I had XP to when I had 7 in terms of the way these symptoms are shown or how the functionality has worked. Ubuntu before Windows was required both times.

My BIOS is the newest for my motherboard. I have used older BIOSs and the problem wasn't any different on those either.

I don't know if the problem can ever be solved given that the drive was built for DVRs in the first place, but if it can be I would like to do it.

I think that this is the specific hard drive model number that is in question, but I can't 100% verify this at this moment:

ST3500312CS Seagate Pipeline HD

- Edit 1 - I wanted to throw it out there that I don't think the computer's power system nor its cooling system have anything to do with the problem. The XFX 650w is well beyond what my max needs are and I have had other PSUs that gave the exact same results. Also, my Lian Li case has huge CFM blasting through it at all times and heat is never a problem for it. I had another worse case that the DVR hard drive was also in (the rest of the system too) and there was again no difference. I will also go ahead and rule out a video card problem as well since it doesn't seem related and I have had two different video cards during this problem and it acted no differently between the two time periods.

I have also had 2 different boot drives that this has performed alongside. The first was an 80 GB (36 NTFS, 36 EXT4, 8 SWAP partitions) and this one is obviously 500 GB (400, 90, 10 partitions). These were always in Sata 0 and the problem didn't change when I changed one out for the other.

All that would make sense, I just wanted to throw it out there as FYIs.
June 22, 2012 2:28:19 AM

this is a long shot but i have the same problem . Have you found any fix for it ?
June 22, 2012 9:24:03 PM

Nope, I didn't. The drive started performing worse and worse and I just got rid of it.

That did clear up the errors pretty quickly, though.
!