No display no beep help needed

Hello :hello:

I have Intel D945GCL motherboard. After proper shutdown my computer when i turned it on i saw an error and startup repair message. So i launched startup repair but when launching it failed and took reboot.After that when again launching startup repair same problem occured but then i'm having no display. My other parts are working individually. I turned on without Ram but still no beep sound. When i turn it on fan of processor is running but having no display. Can anybody help me what problem occured to my mobo?? As my processor is Pentium d 925 so its hard to change my motherboard. Please help me. :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
3 answers Last reply
More about display beep needed
  1. Hello and welcome to the forums
    Try re-seating the CPU and its heatsink.
  2. sorry i forget to mention that just after giving power to SMPS fan of processor starts running. it happens before switch on at cabinet.
  3. Hi there,

    I have same mobo D945GCL,while turn on the PC, the fans spin to max speed forever (in the past time the speed will goes to low speed after 5 seconds) and no beep and no output on the screen.

    The D945GCL mobo has a header named "intruder" on the board (near SATA connectors).I found instructions of mobo the intruder used for "chassis intrusion system--when case of PC opened the system will be protected by no power".

    Please check the header of intruder on your mobo has a jumper on it?

    I hope to discuss with you to solve the problem, because my PC has same issue and have not fixed.

    My email address is zhy40@yahoo.com

    Good lucky!
Ask a new question

Read More

Motherboards Displays