Sign-in / Sign-up
Your question

MK300 Mouse Hangs up

Tags:
  • Mice
  • Connection
  • Keyboards
  • Components
Last response: in Components
March 9, 2010 2:35:06 PM

I bought an MK300 mouse/keyboard set a while back, and I noticed a problem with it, the mouse seems to hang up... just stops moving for about 2-5 seconds all other mouse functionality is fine, if I press the red connect button on the back it usually tends to work again, but for how long? I don't know up to 20 minutes but can be as little as 10 seconds though. haha... if I pick up the mouse and moderately hit it against the desk (sigh, lol frustration) it tends to work again for about the same time as the connect button, and last but not least, the batteries are new. I've also searched the internet for any possible Trend analysis. the keyboard has had no problems and as of right now has worked perfectly. all drivers are updated, and my system specs are as follows

i5-750 @ stock
P7P55D-E PRO
ATI Radeon HD 5850 OC 850/1200 with the latest 5800 series driver set
Corsair 850TX
Geil DDR3 1333Mhz 7-7-7-24 4Gb dual-channel
Intel x25 Gen 2 80Gb SSD
ASUS VW246 Monitor

bleh, the rest of the specs don't really matter
optical drive and data storage drive

I tried another mouse and it works perfectly, it is the Logitech .... I cannot remember the model of the other mouse... its a laser mouse though as opposed to the MK300 being an optical mouse.

funny in the whole ordeal, i updated my display driver, and it updated from my 5850 driver to a standard VGA? took me a while to get my GPU working to where I had it...

I think that is just about it, Ahh the frustrations of life, aren't they wonderful?

So tell me, what do you think? is my mouse just broken? Fix action?

More about : mk300 mouse hangs

March 9, 2010 2:42:02 PM

I have a logitech wireless keyboard and mouse setup and when my mouse starts hanging it was due to a bad battery. This actually happened a day after i bought the setup and the battery that they provided was old and bad so try replacing battery.
m
0
l
March 9, 2010 2:43:49 PM

requiemsallure said:
and last but not least, the batteries are new


^
m
0
l
Related resources
March 9, 2010 2:50:45 PM

Ahh sorry somehow i missed that my bad. Hmm did you try a different USB port?
m
0
l
March 9, 2010 3:10:51 PM

yeah i tried a case port a MOBO USB2.0 port and a USB3.0 port.
m
0
l