DVD-Rom no longer reading DVDs

I am using an ASUS laptop with a Slimtype DVD A DS8A3S. For sometime now I have been having this problem: I can read cd's fine, but it will refuse to read any kind of dvd. When I insert one it makes a few noises, as if trying to read it, then nothing. The unit shows up empty.
Please, I haven't found a solution that works for me, help me.
4 answers Last reply
More about longer reading dvds
  1. You haven't mentioned what you have already tried.
    Try this:
    1. Uninstall the driver in Device Manager and reboot and let Windows install the driver.
    2. Try this Microsoft Support http://support.microsoft.com/mats/cd_dvd_drive_problems/en-us

    Hope something works.
  2. It is possible that the drive is simply on its last legs.

    Are the DVD's you are trying burned or retail(store bought) movies?

    The reason i ask, is there are different DVD types. Mainly Single and Dual Layer(there are also R and RW, but lets just skip that for now). I know my old pioneer stopped reading Dual Layer Dvd's but was still able to read single layer(It was no longer able to read through the first layer to to that portion of the system being dead. Its much harder to explain how that works).

    I also have a bluray combo drive that will read bluray but not DVD's.

    This is simply because the bluray drive has 2 drives in one. so the bluray section(has its own optics and laser) still works, but the DVD/CD sides has died.
  3. I tried both solution and both didn't work. And the DVD I'm trying to read are retail.
    I had the same problem earlier this year, but then I simply cleaned it a bit and the it worked. Now I doesn't.
  4. Sander94 said:
    but then I simply cleaned it a bit and the it worked. Now I doesn't.

    By cleaned a bit did you clean the DVD drive laser lens?

    If you open the drive a qtip with rubbing alcohol(Isopropyl 70-90% higher better) can be used to clean the lens.

    Be very gentile.

    In most cases it is just dust and even a lens cleaner(cd with little fine hair bristles on it) will work.
Ask a new question

Read More

DVD Drives DVD Storage