Sign in with
Sign up | Sign in
Your question

ESATA not being detected in Windows 7 Ultimate x64

Last response: in Storage
Share
December 18, 2011 11:55:37 PM

I built my computer three days ago with an m3a770de ASRock motherboard.

I setup Windows, installed all of the drivers on the disc, and my External HD was being detected with no questions asked, with my HD's setup in IDE mode.

Today it stopped being detected.... There were lots of windows updates... dont know if they had anything to do with it. I tried reinstalling the drivers on the disc. Nothing worked. Scanning in the device manager, unplugging it, etc. Worked through USB though.

So I looked around the internet, and people said to try AHCI mode. I did this (http://www.sevenforums.com/tutorials/61869-ahci-enable-...)

Windows wouldn't boot unless I unplugged my external HD. Upon booting Windows, a bunch of drivers were installed automatically. I plugged it back in and my external hard drive was showing up! And it was hot swappable in eSATA! "Awesome! It worked!"

until....

I restarted my computer, and it still wouldnt boot with it plugged in! So I unplugged it. When I plugged it back in after Windows started, this time it did not show up.

And now I cannot get my external to show up in either AHCI or IDE mode. I'm pissed. It's currently plugged in USB and working that way.

I tried installing my chipset drivers for AHCI, and that didn't affect anything. I'm stuck.

eSATA worked fine, with no hitches, on Windows XP.
December 19, 2011 8:35:32 AM

Anybody :(  Still can't get it to be detected in BIOS or Windows...
m
0
l
a c 372 G Storage
December 19, 2011 11:16:27 AM

Depending on the motherboard/chipset, hot-plug doesn't always seem to work. In these cases, you can sometimes go into device manager and have it "scan for new hardware, and it will detect the drive. It's a pain in the butt, but it beats a reboot.
m
0
l
Related resources
December 19, 2011 11:43:40 AM

Rebooting in IDE mode doesn't work. Scanning in the device manager doesn't work. It doesn't work in IDE or ACHI mode. I explained that in my first post.
m
0
l
a c 372 G Storage
December 19, 2011 11:53:55 AM

You can try this at your own risk. I've used it before and it has worked. Sometimes the drive mappings get messed up from plugging/unplugging so many devices.

Run it from a command promt as administrator. I recommend running it in test mode first so you will see what it will clean up. Use the help option to see all the command line options.

http://www.uwe-sieber.de/drivetools_e.html#drivecleanup
m
0
l
December 19, 2011 12:07:54 PM

Didn't work. I'm thinking it might be a issue relating to my motherboard; because my BIOS should detect it regardless of whether or not Windows does.
m
0
l
a c 372 G Storage
December 19, 2011 12:19:13 PM

Ah, yes. You didn't mention it was not showing up in the bios.

If it did show up in the bios, you would need to run that program I linked to above while the easta is not plugged in, and plug the drive in afterwards. I think I forgot to mention that above.
m
0
l
December 19, 2011 12:24:21 PM

yeah, I figured that would be the case... but either way, its not showing up in the bios, so I'm stuck. I really dont know what to do... especially considering it was working at one point both with my storage config set to IDE and AHCI in the bios. I'm starting to think maybe its the cord?

But the only reason I doubt that is because when in AHCI mode, Windows won't boot or shut down with the drive plugged in, despite not being displayed in the BIOS.
m
0
l
a c 372 G Storage
December 19, 2011 2:14:56 PM

If you have a spare computer, try installing the drive in it and see if it shows up there, otherwise you're probably right and it may have died.

You might also want to try clearing your bios, load optimized defaults, change any necessary settings, then try your drive again.
m
0
l
December 19, 2011 11:09:51 PM

Yeah, I've tried the optimized defaults... I'm thinking its the cord. I don't have another computer with eSATA.... although when I go home for christmas, my brother does. So I guess I'll try connecting it then, to see if its the cord or not.
m
0
l
!