Sign in with
Sign up | Sign in
Your question

Problem w/ new build, help! Error: Reboot and select proper boot...

Last response: in Systems
Share
January 5, 2010 3:53:32 AM

Hi People of wisdom,

I recently built a new machine for 3D graphics, CAD, and Photoshop and stuff. I'll be using it for my studies in architecture.

The specs are as follows:

CPU: AMD Phenom II X4 3.4 ghz 125W

Mobo: ASUS M4A79XTD EVO AM3 AMD 790X

RAM: Mushkin Enhanced Redline 6GB DDR3 1600

VGA: ATI FirePro V5700 512MB PCI Express 2.0 x16 Workstation Video Card

HDD 1: Western Digital Raptor 10k rpm 150gb

HDD 2: Western Digital Caviar Green 500gb

DVD: HP 1260i 24X Multiformat DVD Writer

PSU: SILVERSTONE ST85F-P 850W ATX 12V v2.3 / EPS 12V 80 PLUS SILVER Certified Modular Active PFC Power Supply

Those are what I believe to be the critical specs, if anymore info is needed let me know.

The problem:

So I put the whole machine together no problem and then I booted it up and the screen just after the mobo logo and hardware screen briefly blinks "No Hard Disk Detected!" Afterwhich the screen read, "Reboot & select proper boot device or insert boot media in selected boot device & press any key to continue" I have a windows XP disk in the drive that I have used a million times, so I know it works, but after hitting any key the same message reappears.

So of course I checked the bios and it reads the hard drive (only the WD Green for now as the raptor is still on its way) as being there. It also reads the DVD drive as being there. So I changed the boot order first to be the 500gb hard drive being first and the DVD drive being second. I saved and exited. Then upon restarting I got the message again. So I changed the boot order to the DVD drive being first and the HDD second. Same message. I then checked all my cables and even swapped the SATA cables for some spares I had. Same message. I then gave the hard drive its own power cable from the power supply; same message.

So then I thought it must just be the hard drive itself. Wrong. I checked the HDD in my other working desktop and it detected it and even recognized it Windows XP.

What's the solution?

If it is not the boot order, not the cables, not the power supply, and not the disk itself, what is it? I have no idea.

Is there anyone who has had the same problem or knows how to solve it? IF SO, HOW!!!

I plan to give ASUS tech support a call, but I was hoping somebody had a faster solution for me on here.
January 6, 2010 8:36:42 AM

Does nobody know how to fix this issue? Or did I perhaps post this in the wrong forum subsection?

Thanks.
m
0
l
January 6, 2010 9:53:51 AM

^ Could you give the correct model number of the CPU ?
Is it X4 965 ? and if you can, get the CPU revision...Is it C2 or C3 ?
And could you check the BIOS version on your mobo and the BIOS version currently available from the ASUS website are the same...
The reason am saying this is because the old BIOS that come with the board doesnt support the X4 965 3.4GHz 125W C3 revision CPU...You would have to update the BIOS to the latest one for it to support...And as of yet, it is not confirmed that whether the new shipments come with the new BIOS...
m
0
l
Related resources
January 6, 2010 7:10:43 PM

Hi gkay09,

The CPU is Phenom II X4 965 Black Edition Deneb C3 125W

The bios version is V 02.61.

I read about the problem between the C3 125W 965 cpu's and this mobo's bios, but the processor shows up in the bios as being there, so I'm not sure if that is the problem, but then again I don't know what the problem is.

I received an email from the Asus tech support people saying I needed to install the drivers for the SATA controller, but I haven't even been able to install an OS yet, so I'm not sure if they even read my email.

If there is anymore info needed let me know!

Thanks for any help!
m
0
l
January 6, 2010 7:46:12 PM

I'm sorry, BIOS version is 0605.
m
0
l
January 7, 2010 2:13:23 AM

^ That BIOS version does support the C3 revision...
And check for any HDD configuration in the BIOS...See if there are any options like AHCI/ SATA mode ? If there is an option, then try changing it to IDE mode and see if that works...
I think for WinXP, you might have to install the SATA drivers separately...but my WinXP did recognize the SATA drive without any need for drivers on the new mobo but for old mobos, that was required...but still worth a try...
And also try flashing the latest BIOS - 0704...
m
0
l
January 7, 2010 10:30:33 AM

Thanks for being willing to help gkay09, nobody else seems to know how to fix this problem, even ASUS.

The HDD and DVD drives are both set to IDE, I explored that issue a while ago.

I am unable to install the SATA drivers as I have not even been able to install an operating system yet. I've tried booting from 3 different discs, 2 of them are untested Windows 7 Ultimate 64-bit editions, and one of them is a tested and proven 32-bit XP Pro disc. I think I mentioned this, but when it gets to that 'insert boot media and hit any key to boot from disc' screen and I hit any key, the thinking light on the front of the DVD drive blinks for a second or so and then goes out and the insert boot media message reappears.

I have not tried flashing to the newest bios yet. I'll try that after I see what ASUS says a second time. When flashing the bios, do I burn the new version to a CD with another computer and then load it off of that or can I use a thumb drive? I know where the easyflash menu is located, I just haven't flashed a bios before.

Anyway, thanks for the help again.
m
0
l
January 7, 2010 11:28:41 AM

Thanks for the link. I'll try flashing the bios and see if that helps.

And in reply to your question, I tried both in all modes, still same error.
m
0
l
January 8, 2010 9:06:21 PM

So I tried flashing the bios and it said that there was an error erasing blocks? And then it aborted.

I'm about ready to just exchange my board for a new one, this has been ridiculous! Nothing seems to solve this problem!!!!
m
0
l
January 11, 2010 2:30:40 AM

^ Too bad...And even am out of ideas...hopefully that was just a faulty board...
and do post about the new one too...
m
0
l
!