Sign in with
Sign up | Sign in
Your question

Super Annoying Freezing Mouse

Last response: in Windows 7
October 14, 2011 8:27:47 AM

So I just built a new pc, formatted and all, and everything was great - till a few weeks in I started having this problem with my mouse (and sometimes keyboard). After an indefinite amount of time, my mouse will just FREEZE. Completely unresponsive. Won't move an inch, clicks/scrolls rendered useless. Sometimes it's my keyboard too.
a) mouse will freeze and the keyboard too. backlight (microsoft sidewinder x4) on keyboard will blink really fast
b) mouse will freeze but keyboard still works fine
or c) keyboard will still work but the mouse will lag/unsmooth (will freeze for half a second in a spot)

the only unfailing remedy at the moment is to push power button once which puts pc to sleep, then push any key and it'll wake up

What I've tried: Switching usb ports at freeze, reinstalling mouse drivers, virus/malware/spyware scan, closing unneeded programs
SOMETIMES I can switch to another usb, then it happens again, so I switch again, and on and on (I have 12 usb ports) but then either I run out of ports to switch to or they just dont work.

It is a dell optical mouse, red light on the bottom which stays on, so it is getting power. mouse works on another pc

I dont think it's a problem with mobo*, since case usb doesn't work either.
After mouse freezes, I can plug in a logitech controller which will be recognized so I think the port is fine.
What I'm wondering is, how exactly do you go about diagnosing/fixing a pnp problem, and
If I wanted to reinstall the usb drivers from device manager, how would I reinstall them?

The only other hint I can give is, this may have possibly started after an windows update, which btw is all up to date.
*I haven't tried system restore as I have no restore points atm.
*Motherboard :
Windows 7 x64
Not sure if I posted this in the right section or not but...
Any tips/solutions, even if they may obvious and non-helpful, will be happily accepted.
Thanks. :) 
a b $ Windows 7
October 17, 2011 1:11:07 PM

Hi AllYourBass, did you install ALL your motherboard drivers after fresh install of Windows 7?

The default Windows drivers are ONLY to allow install of OS and do NOT include all functionality and optimization for your motherboard ( which is right on cutting edge, usb3/sata6 wise!).

You may want to check if the Windows update included any USB drivers for your board, and if so, uninstall and install only manufacturers drivers for USB.

Check out and re-install motherboard drivers and let us know how you get on :-)

PS, are you connecting mouse and keyboard to any external USB3 ports, if so this could be a problem if motherboard drivers are not installed! ( they are backwards compatible with usb2 devices? ).

PPS, have you installed or added any other USB peripherals to system and installed on same ports as you usually use for keyboard and mouse?

PPPS, are your bios settings for USB setup properly eg, hi-speed, legacy settings etc, check these out too!
October 17, 2011 10:07:15 PM

Yes all mobo drivers are installed

None of them say anything about usb

I reinstalled the drivers but those drivers are only for usb 3.0

There are 2 usb 3.0 ports on the motherboard and they have drivers. I only plugged into 3.0 when just trying to find something else to plug into.

Keyboard and mouse were originally plugged in top usb's (next to a ps/2, so I think those are meant for mouse and keyboard). After a freeze, I can plug in my logitech controller and it'll work/be detected.

I also forgot to mention that sometimes I randomly hear the sound of something being plugged in and out. Is there a way to... reinstall pnp? That sounds weird.
Related resources
a b $ Windows 7
October 18, 2011 10:07:54 AM

Hi AllYourBass, thanks for reply; your comment about occasionally hearing something being unplugged and plugged in ( the default sound when you connect any device to USB ) is crucial!

It may confirm that the Motherboard is faulty on the USB! Without you doing a fresh install to see if clean system exhibits the same behavior, not sure what to suggest.

Does any other USB device have the same issues with working, not working? Have you another keyboard mouse to test without going and buying one ( hate having to buy another item to confirm if one i already own is dud! ).

Have you another PC to test keyboard and mouse on, not a adequate solution, but at least will tell you if its your setup/hardware which is at fault.

PS, check in bios for settings related to USB keyboard and mouse, may be trying to power on here which could be causing your problems.
October 21, 2011 4:20:31 PM

So I thought it went away.. but that was only for like a day.
I updated bios to f6 (and reinstalled other mobo drivers), checked for options there but nothing really.
I don't have another mouse to test with.

I enabled the keypad mouse and went to device manager after it happened again. Under other devices, 2 Uiniversal Serial Bus (USB) Controller appeared with !'s

What do I do?
a b $ Windows 7
October 22, 2011 11:18:35 AM

Hi allyourbass, without another mouse to test, for me, the only option you have left is to consider the motherboard faulty on the usb ports. Since this problem does not seem to affect anything else you plug into these ports, it must be the mouse itself which is faulty!

Get another mouse before you consider it a problem with motherboard.
September 6, 2013 9:41:58 AM

While this is an old question, I'd like to post a likely solution anyway. Windows 7 in particular really follows the power-save trend that so much software and hardware seems to popularize nowadays. In style with that power-save approach, Win7 tends to shut down any device it suspects to currently not be in use. Unfortunately, Win7 rather fails with this detection in the USB department and thus shuts down mouses, keyboards and external HDD's, only to find it still being in use when the user frantically clicks the device as soon as it freezes.

To solve this, go to Control Panel > Device Manager and view the properties of your USB devices. When viewing the properties, go to the Power Management tab and untick the box that allows the device to be shut down in order to safe up energy. This might very well fix your problem!
January 13, 2014 3:42:33 AM

Dear Saratje,
thank you for your hint: you solved my trouble!