Sign in with
Sign up | Sign in
Your question
Closed

Boot Error from USB

Last response: in Motherboards
Share
July 31, 2010 4:28:35 AM

I have a USB stick formatted with FAT32 with Ubuntu 10.04 installed to it. It is verified to be working on another computer.

I booted up the Gigabyte 785 and selected USB-HDD from the F12 menu and on screen it tells me.

...
Verifying DMI Pool Data
Boot error

I don't have a CD drive so I'm going to need to be able to boot this sucker with USB somehow.
What can I do?

More about : boot error usb

a c 177 V Motherboard
July 31, 2010 1:11:05 PM

Have you tried changing the BIOS' boot order on the "Advanced BIOS Features" page? Also, check on the "Integrated Peripherals" page - "Legacy USB storage detect" needs to be set to "Enabled" (should be, by default, but worth checking...) Might also read the USB Woes item under Troubleshooting: in the 'sticky' - may need to try a different stick...
Score
0
July 31, 2010 1:28:08 PM

Yes I changed the boot order to first boot device USB-HDD. No go. I even tried unplugging the SATA hard drive. No go.
Yes Legacy USB storage detect is enabled.

I went into Q-flash and reset those things and when that didn't work I reset the CMOS. And that didn't work either. I hope my board is not defective.
Here is my hardware:
AMD Athlon II 3.0Ghz
1.0TB Caviar Green 5400rpm (new)
2x2GB DDR2 800DIMM G.SKILL
270W power supply integrated with hEC case.
Micro ATX Gigabyte 785

FWIW I read USB woes and that doesn't seem to be the problem either. I do have a wireless logitech keyboard plugged into a USB port. Maybe Gigabyte is trying to boot that?
Score
0
Related resources
July 31, 2010 1:41:25 PM

Sometimes it would give me some warning about how a SATA drive was connected and acting as an IDE then and it gave me the option to say Y or N or continue, but the message always disappears after what seems like five seconds. So I have tried both (Y once and N after I reset the CMOS) to no avail.

Whole bunch of stuff in a table.
Then...

ACPI Controller 9
Now it says Verifying DMI pool data..............
DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER.

I don't have a CD Drive. What's going on Gigabyte?
Score
0
a c 177 V Motherboard
July 31, 2010 1:59:56 PM

Kind of a busy day, but I can give it a try, later, if Murphy's Law doesn't "expand job to consume all available time and resources". I have Ubuntu d/l's here, and at least one bootable USB (by that I mean - one that won't corrupt my CMOS if I forget, leave it in, and inadvertently reboot the machine!)

Here's another thing to try (someone 'picked this up' from GB tech support, and I haven't a foggy clue how it can work - only that it sometimes does): set your first boot item to your USB, and set the second one (and I'm vague here, as I can't look up the wording GB manuals don't document the item, but all have it...) to "bootable disk controller card" - again, wording likely different, but I'd have to boot to see it, and I'm in the middle of a largish TechNet d/l...

Have you tried something like the HP format tool to make a 'plain vanilla' DOS boot stick? Will it boot?
Score
0
July 31, 2010 2:30:20 PM

There is no bootable disk controller card (or anything remotely like it?) from the options in first, second, and third boot device. However, under the _hard disk boot priority_ there is an option to select scsi 0 (my 1tb Western Digital) and 2. bootable add-in cards.

I made bootable add in cards number one and I added Hard disk to the number 2 boot priority. Then when that didn't work I switched my boot order devices: made Hard disk first priority and USB HDD second. That didn't work either.

I'm about 10 seconds (maybe a small exaggeration) away from RMAing this board and ordering an ASUS board. My other computer has ASUS and I just booted this USB from that computer flawlessly.

Can I boot from LAN and somehow install Damn Small Linux?
The fact that Gigabyte cannot boot from USB is extremely unfortunate.
Score
0
a c 177 V Motherboard
July 31, 2010 3:26:57 PM

Am making a test stick as I post. Did you enable 'persistence'?
Score
0
July 31, 2010 3:42:39 PM

I don't see what's wrong with the stick. I've tested it on two computers now and it boots and works fine there.

I don't see any mention of persistance in the BIOS, the manual or Google.
Score
0
a c 177 V Motherboard
July 31, 2010 3:51:26 PM

I'm just trying to recreate the problem, here... 'Persistence is an option in the universal USB installer - appears to set up the drive so it will retain changes made to the Ubuntu config while running it, so the same changes 'persist' through the next boot; just concerned that it may make changes to the boot structure, which is what I want to examine...
Score
0
July 31, 2010 4:03:36 PM

I haven't made any changes to the USB drive. When I created the USB, I used the Startup Disk Creator in Ubuntu, which has never failed me in the past.

I selected discard changes. The problem does not lie in the USB. The problem is the Gigabyte BIOS. Is there nothing I can do to boot from USB? Because it certainly seems that way.

I feel betrayed by Gigabyte. I will never buy another product from them and I am kicking myself for not getting the ASUS.
Score
0
a c 177 V Motherboard
July 31, 2010 5:45:17 PM

Ok - made the bootable Ubuntu, but used this installer from windoze to save a reboot and 'groping around' in Linux, which I don't use often enough. Set BIOS to boot from "USB-HDD", with "Legacy USB storage detect" enabled - booted straightaway. Examined stick's MBR - pretty standard, 'plain-Jane' boot record. At this point can only recommend a few things: try the same installer with any convenient ubuntu.iso you have; try the 'old faithful' HP stick format utility to create a DOS bootable to double check; try a different (or, a few different) stick(s) - might just be a case of the well-know USB 'pickiness' that GBs in general exhibit... I can tell you a couple that won't work: don't bother with OCZ 'Deisels', or SanDisk 'Cruzers' - known incompatible...

Lacking an 'inside contact' with GB who could explain the phenomenon, I can only guess at the root cause, but I suspect GB BIOS are just more demanding of strict compliance with the USB specs - I guess at this, as a few cases of known 'non-working' devices (specifically some WD USB external backup drives, and [can't recall the manufacturer] a USB CD/DVD drive were later 'fixed' by new firmware from the mfgs... I have never been particularly put out by this, as I'm a fossil [:bilbat:6] - I think we were on win95 or 98 when USB was first introduced... Then, if you could get any USB device working at all, you were considered both lucky, and a 'wizard' - and to get two working at once, on the same system - plainly impossible! [:isamuelson:8]
Score
0
a c 177 V Motherboard
July 31, 2010 6:28:26 PM

[:bilbat:9] ...do I take that to mean you don't have windoze on your system? If you give me a quick tutorial on where to find the 'stick maker' in Ubuntu, I can try that - would prefer 32bit, as 64 sometimes breaks one of my 'fakeraids'; only sometimes, and only one of the three RAID pairs, so I've been avoiding it until I can get around to putting in 10.04 - current version is 9.1 here...

Perhaps I need clarification here - if you posted basically to have a place to b!tch about it - I can respect that, but don't want to invest any more time if you're not really in search of a solution!
Score
0
November 12, 2011 10:26:54 AM

Maletor said:
I haven't made any changes to the USB drive. When I created the USB, I used the Startup Disk Creator in Ubuntu, which has never failed me in the past.

I selected discard changes. The problem does not lie in the USB. The problem is the Gigabyte BIOS. Is there nothing I can do to boot from USB? Because it certainly seems that way.

I feel betrayed by Gigabyte. I will never buy another product from them and I am kicking myself for not getting the ASUS.



I exactly know your feeling. I have been trying to solve the gigabyte usb problem for about two months. It is the bios but what they don't tell you it is the brand /make of the usb if the bios sees the usb. Once the motherboard detects a likable usb then all is like one would expect..
Score
0
April 22, 2012 2:51:21 AM

Hey Guys,

I know this thread is ages old. But i just had and resolved this problem, I hope this post will help someone else.

When you insert a USB Stick and try and boot of it. You need to change the Hard Drive Boot order in the Bios to the name of the thumb drive (it will be in the list as a detected item)

IE. Instead of selecting USB-HDD as the boot option, Select Hard drives and then select the name of the Thumbdrive from that list.

Hope this makes sense.
Score
0
!