Sign in with
Sign up | Sign in
Your question

Core i7920 turbo boost problem?

Last response: in CPUs
Share
March 12, 2010 6:25:15 PM

i downloaded turbo boost meter from intel.com and it shows you if your processor is using turbo boost. Well mine is but the problem is that its always on. Like its always running at 2.8 ghz instead of the normal 2.6. i thought turbo boost was only supposed to kick in when you needed it, like playing a game or something. How do i fix this?
a c 180 à CPUs
March 12, 2010 10:51:05 PM

Try CPU-Z instead ... if it shows you running on turbo all the time, check Task Manager and see what's cranking on your CPU.
Related resources
March 13, 2010 2:03:20 AM

cpuz says its running at 2.8ghz. i checked task manager and theres absolutely nothing running in the background. cpu usage is at 0-1%. Is there maby a setting that should or shouldnt be enabled in the bios like speedstep or something
March 13, 2010 1:22:12 PM

i just installed it on my computer and it says at idle it runs at 2.6 but everytime i open a program it jumps up. i have the intel i7 920 two.
March 13, 2010 6:29:44 PM

Do you have C-states and speedsted enabled in the BIOS?

What processor do you have?
March 14, 2010 2:54:04 PM

ok you lost me. i don't know what C-states and speedset are. The only thing i changed in my BIOS was my memory so it would run at 1600. I have the intel i7 920.
March 15, 2010 7:28:40 PM

In your BIOS there should be a menu, either of power saving feutrues or processor features. Find it and you should see an option for Intel Speed Step enable/disable and C-States enable/disable

Speed Step lets the CPU throttle back under light load and C-states allow it to basically take a nap
March 16, 2010 11:46:05 PM

oh i see thanks hey do u know how to get rid of blue screen
March 17, 2010 1:08:06 AM

Also it can depend on what your power properties are set to. On mine for a while cpu-z would always show mine at 21x multi no matter what it was actually at. Also the actual multi would bounce around a lot when idle. I found the solution was to (using XP) change the power properties from desktop to portable/laptop. That allowed it to have a stable 12x at idle and 21x at load and cpu-z started to finally report the correct multi.

Here is a shot showing what it looked like with cpu-z reporting the incorrect multi.



And here is a shot of what I changed to correct the problem.



And same was true in W7 RC but had quite a few more options to set but I started with power saver mode and changed from there.

!