Sign in with
Sign up | Sign in
Your question
Solved

Help explaining large discrepancy in SSD benchmarks after reformat

Last response: in Storage
Share
a b G Storage
December 27, 2011 4:54:34 PM

I have a Crucial M4 128GB SSD for my boot drive. The following are two benchmarks of that drive - the first was run in mid-November and the second was run today.

November's AS SSD benchmark (link):
*Seq - 501MB/s (read) / 200MB/s (write)
*4K - 26MB/s (read) / 69MB/s (write)
*4K-64Thrd - 287MB/s (read) / 161MB/s (write)
*Acc.time - 0.079ms (read) / 0.198ms (write)

Today's AS SSD benchmark (link):
*Seq - 502MB/s (read) / 200MB/s (write)
*4K - 25MB/s (read) / 3MB/s (write)
*4K-64Thrd - 283MB/s (read) / 101MB/s (write)
*Acc.time - 0.090ms (read) / 1.310ms (write)

Small discrepancies are one thing but the large drop in 4K write (3MB/s down from 69MB/s) and write acc. time (1.310ms up from 0.198ms) worries me a little. The biggest difference in my system between those two benchmarks is a reformat and the installation of a 5.25" to 4x2.5" backplane which now houses my boot drive.

Any ideas?

Here's my full system if it matters:
i5-2500K
ASUS P8Z68-V Deluxe
MSI Twin Frozr II HD 6950
G.Skill Ripjaw 16GB
Crucial M4 128GB
Several supplemental drives
Corsair HX650
Zalman Z9 Mid-Tower
a b G Storage
December 27, 2011 5:21:04 PM

did you formatted your SSD or wiped it ?
m
0
l
a b G Storage
December 27, 2011 5:33:26 PM

armand_h said:
did you formatted your SSD or wiped it ?


I reinstalled windows. During the windows installation when it asked me where to install windows I deleted the old partitions and created a new one (two if you include the 200mb system partition).
m
0
l
a b G Storage
December 27, 2011 5:44:09 PM

do it then test your drive and share the results with us!;)
m
0
l
a b G Storage
December 27, 2011 6:44:17 PM

Can I use windows backup to save an image of my boot drive, use gparted to wipe the drive, and then use my installation disk to restore the image? If I have to reinstall everything from scratch then I will, but I'd like to avoid that if I can.
m
0
l
a b G Storage
December 27, 2011 6:53:17 PM

just read about Backup of Disk using Acronis!
that's what you need!:) 
m
0
l
a b G Storage
December 27, 2011 10:11:46 PM

Gparted didn't work. The "hdparam" didn't want to work without a root password, even though there isn't one, and the "--security-enhanced-erase" command didn't work either.
m
0
l
a b G Storage
December 28, 2011 1:34:19 PM

what do you mean it didn't work?
you mean that you did as what they said and still the same results?
m
0
l
a b G Storage
December 28, 2011 2:19:03 PM

armand_h said:
what do you mean it didn't work?
you mean that you did as what they said and still the same results?


I mean that I wasn't able to do what they said. I backed up with Acronis, made the GParted boot disk, booted into GParted, deleted the old partitions, and then tried to wipe the drive in the terminal.

The "hdparm --security-erase NULL /dev/hda" command (I also tried several variations) did not work. Despite the --security-erase flag it was still asking for a password which is strange because there is no password. I also tried to get root access but the "su -" command was also asking me for a command. (And yes, I tried "sudo hdparm --security-erase NULL /dev/hda" but that also asked for a password.)
m
0
l

Best solution

a b G Storage
December 28, 2011 2:43:24 PM

strange!
many ppl doing the same thing for m4!

here step-by-step guide :

set your bios to boot to the cd drive first. i had my storage chipset set to ahci, and put the drives i wanted to erase on the first few sata ports.

Boot to the iso. once it is loaded, you will get a window asking if you want to run in ram (default). chose this.

you will then get to the parted magic desktop.

down in the bottom left, there is something like the windows 'orb', or start icon. click it.

you now have a menu. chose "erase disk".

when the next window pops up, choose the bottom (4th) choice, "internal: secure erase command...", then "continue".

now you should see a drive or drives on your system listed. chose the drive you want to erase, then hit "ok".

you will get prompt for a password. leave it "null", and continue.

you then get a warning "continue at your own risk...". continue.

you should see a fleeting box pop up and disappear. your drive is done. takes a few seconds
Share
a b G Storage
December 28, 2011 2:50:32 PM

you would have to 'hot plug' the ssd if you get the 'frozen' error or you can't remove the password.
while the system is under ahci, place the parted magic .iso in your optical drive, then power down.
remove the signal cable from the drive (leaving the power connector attached), and be ready to re plug the signal cable.
power up the system, and after your bios posts, and you first see the first splash screen of parted magic (asking you if you want to run in ram), re plug the signal cable into the ssd.
when you get to parted's gui, you should have an unlocked drive.

i had the same problem with intel 320 series and it worked! and will work for you!
m
0
l
a b G Storage
January 5, 2012 3:59:57 PM

Holy crap it actually worked. After using parted magic my speeds are almost back where they were when the drive was new. My 4K write speeds are a bit lower at 60 MB/s but I'll certainly take it. Thanks armand_h.

For anyone reading this thread in the future - gparted didn't work at all but parted magic worked fine.
m
0
l
a b G Storage
January 5, 2012 4:00:19 PM

Best answer selected by danraies.
m
0
l
a b G Storage
January 5, 2012 6:05:40 PM

no problem!I'm glad that I could help you! :) 
m
0
l
!