Sign in with
Sign up | Sign in
Your question

HIS 5770 refuses to run in x16 only x8 mode

Last response: in Graphics & Displays
Share
January 5, 2010 7:03:31 PM

So I have an HIS 5770 that refuses to run in x16 only x8.
System:

Core i860 @ 4.0Ghz
EVGA p55 SLI
Corsair XMS DDR3 1600

First tried all the latest drivers for the card and the chipset and then tried older video drivers.

Flashed the BIOS to latest still nothing.

Took the card out and put a 9800GTX in and it ran at x16 with no problem.

Moved sound card to other slot, nothing

Reset Bios, ran stock, nothing.

Increased PCIE Bus to 105, 110, 115, 95, 100 nothing

Reseat the card numerous times.

The only thing i can see is the heat sink on the fan is heavy and pulls the back of the card somewhat down, so maybe not making good contact in the seat?

Dunno, Anyone else have insight?
a c 216 U Graphics card
January 5, 2010 7:27:52 PM

Strange, but the good news is the 5770 is not going to bottleneck on x8 from everything I've seen.
m
0
l
a b U Graphics card
January 5, 2010 9:41:49 PM

If you're running Windows Vista go to Control Panel > Power Options > and go to change plan settings under whichever plan is currently selected > Change advanced power settings > PCI Express > Link State Power Management.

Change the setting to off and see if that fixes it. If it doesn't then change it back to the way it was so you won't be wasting power :]

If that didn't help then good luck :[
m
0
l
Related resources
January 6, 2010 2:03:51 AM

You will not benefit for the 16X anyway... if it was a 5970... I would say otherwise.
m
0
l
a c 130 U Graphics card
January 6, 2010 5:52:02 AM

I have seen this happen before its just down to how its reporting the card a PCIE 2.0 card reported at X8 is the same as a PCIE 1.0/1.1 card reported at X16. Dont know exactly why it does it.
Check your bandwidth against the reviews and as long as thats about right you are fine.

Mactronix
m
0
l
!