Sign in with
Sign up | Sign in
Your question

Weird problem: first boot always crashes, hard reset fixes it

Last response: in Systems
Share
January 11, 2010 6:08:21 AM

Hi guys,

I have a real strange problem with my machine. Each time I boot the computer for the first time, I log in and within a few minutes I get a hard crash (i.e. no blue screen, just a grey mess). After I do a hard reset, the problem goes away until the next day when the whole process starts over.

I have had this machine since Windows 7 was released and the problem first presented itself the first time I booted up my machine! After much mucking around with RAM combinations, I found two chips that worked together and had zero crashes in a period of about 3-4 weeks. I do, however, want all the RAM working, so here we are.

What happens:
- I turn computer on
- It makes it through the POST with no issues
- I log in to Windows
- After (usually) a few minutes, various programs start having problems (e.g. Firefox will crash, Event Viewer falls over etc).
- Very quickly, things head south and it crashes. If it helps, the HDD light stops flashing. The screen is sometimes solid grey, sometimes it has vertical lines. If need be I can take a picture next time it happens.
- To get things started again, I do a hard reset which results in the computer running fine. To clarify, it has never once crashed again following the hard reset (at least until the next day).

Specs:
- Core I5 750 2.66Ghz
- MSI P55-GD65 mobo
- 8GB G.Skill Ripjaw Ram DDR3-1333 (4 x 2GB)
- Arctic Cooling Freezer CPU cooler
- MSI Radeon 5850
- Vantec ION 620W PSU
- Seagate 1TB 7200RPM SATA2 HDD
- Windows 7 Home Premium (all updates)
- Thermaltake Element G Tower case
- Nothing is overclocked

Stuff I have tried:
- As described above, I have tried various combinations of the RAM. Two of the sticks work without issue.
- The crash still happens in Safe Mode, but at least I get a blue screen. The errors have referred to either MEMORY_MANAGEMENT or BAD_POOL_HEADER.
- Running the Windows Memory Diagnostic. Before the crash, it states that hardware problems have been found (and does so immediately). After the hard reset, no problems are found.
- Running Memtest+. I once ran this overnight after the hard reset and it found no problems. I also booted directly into it at first boot and it didn't find anything then, either.
- Updating video drivers. Made no difference but I don't feel as though the GFX card is the issue.

Any ideas? I have spent plenty of time searching for solutions but thus far found nothing. I would really appreciate some help with this one.
a b B Homebuilt system
January 11, 2010 12:24:42 PM

I was having a very similar problem.
Finally I switched from G-Skill ram to Corsair ram and all problems went away.
If you have different memory ,give it a try.
a b B Homebuilt system
January 11, 2010 12:37:31 PM

This does have the sound of memory not quite stable, although I must admit it is puzzling that it "fixes itself" with a hard reboot. I suggest two things to check in your BIOS settings.

1. Sometimes the BIOS gets the wrong information from the RAM modules on their voltage requirements. Get the voltage specs from the G.Skill website for your RAM modules, then check in BIOS what voltage your mobo is providing to them. If it's low, manually set to specs. Or even, if there is some leeway according to G.Skill's specs, raise your mobo's RAM voltage setting a small amount.
2. Also get the timing spec for your RAM and verify whether your mobo is using those values. If not, check with G.Skill's tech Support people on whether you should change something.
Related resources
January 13, 2010 8:33:14 AM

Just so you don't feel alone - I have the exact same problem (my hardware is completely different though).
January 23, 2010 7:52:43 PM

Sorry about the lack of updates, caught up in RL stuff etc.

Thanks for all your help on this one! I think I may have solved the problem - will post back in a few days once I have confirmed it.

My initial attempts involved changing the voltage and checking the timing as suggested by Paperdoc. This didn't solve the problem, but I did find that my RAM was set to run at 1N rather than 2N. I set this to 2 to be in line with the RAM specs.

My testing yesterday indicated that two sticks of RAM worked fine (any two, in fact), but the problems only exhibited themselves when I had all four sticks of RAM running. After a quick call to tech support I was told to increase the CPU VTT voltage from about 1.0 to 1.25. Thus far I have had no more crashes!

Although this does not explain all my problems (I have had this issue with just 1 stick in there) I will gladly take it.

Thanks once more for your assistance, and hopefully this also proves helpful to RoBorg.
January 23, 2010 9:46:37 PM

This sounds like a PSU problem to me. It can't handle the amp load from a cold boot, but after it's been on a few minutes it has warmed up enough to work just fine. Explains why a reboot fixes your problem. And also why taking out some RAM fixes it as well, even though you've tested and all of it is good.

Never used/seen Vantec, but a quick google search let me know it only has 2 12v rails @ 22amp. If it's low quality I doubt it's even giving you that much power.
January 25, 2010 5:18:29 AM

Sadly, it looks like the problem has come back. It happened tonight, died on the first boot then came right on the next. This is a pain as it ran fine all weekend with some pretty heavy use.

calinkula, do you have any advice about verifying whether the power supply is the issue? This is something I haven't considered yet, and after tonight I am wondering if you are right. Unfortunately, I don't have a spare power supply nor any spare RAM, so those avenues are not open.

Edit: would anyone recommend updating the BIOS? Currently I am running version 1.0, but according to the MSI website version 1.6 is available.
February 19, 2010 1:00:21 PM

I've also been having this problem, since I built the computer about 2 months ago.

- Core I7 920
- Gigabyte X58A-UD7 mobo
- 6GB Kit (3x2GB) G.Skill-Trident DDR3 2000
- XFX 5870 XXX Edition
- OCZ Z Series 850W PSU
- Western Digital Caviar Black 640GB
- OEM Windows 7 Pro (64bit)
- Coolermaster HAF932 Case
- Nothing is overclocked as well, in fact the graphics card is underclocked (from specs) to solve the 'pinstriping' crash issue of some the latest ati cards.

The only thing I can really see similar aside from Windows 7 is the G.Skill RAM, even though its a different set, I still have my qualms about it as I had similar problems to begin with getting the RAM to all work.

Originally the whole thing would not even post with all 3 sticks in, after finding no problems in memtest and running each stick individually for days without problems I reset the RAM settings in the BIOS to default (not that I'd changed them to begin with) and this allowed me to run all three sticks fine, until I started having this problem.

To clarify, the first boot after being off for more than a few hours will have various issues. Sometimes BSOD, or black/blank screen, but always a random program will crash (explorer, steam, winamp, vlc, firefox, msn, etc seems it can be anything) and then it will crash in some way. Either a hard reset at this point or if I'm quick enough shutting down via the start menu will mean the second boot is flawless and can run for days.

After reading the post from Rick_Criswell I'm thinking more and more its the RAM. Wondering if I should suck up and replace it with a different brand, keep tinkering with the BIOS settings or just learn to deal with it... unless there are any other ideas?
February 21, 2010 12:03:57 AM

I'm in the exact same boat as you guys and again the common denominator is the G.Skill Memory. I have a different mobo etc than you guys but have the exact same problem. It always gives me a BSOD on the very first boot of the day only. I can reboot a million times after that in a day and they're all good. I even switched back to Windows XP 64 bit and it happens there to.
I have done so much searching and a lot of people have this problem but noone has a solution. And guess what kind of memory these people have? G.Skill. There's one post where a guy got it resolved by changing his memory to Corsair.
A bunch of others say it's the power supply but noone has reported this solved anything especially seeing benjic has a 850W power supply. Myself, I am only using a 500W unit so I thought that could be it but all this G.Skill talk is really making me think.
I'm running an i5 750 on a Gigabyte UD4P mobo with a OCZ SSD with backup seagate HDD. And of course there the dreaded G.SKILL F3-12800CL9D-4GBRL Ripjaws PC3-12800 8GB. Maybe 500W is too low but I'm a daytrader and stress my machine all day and it never locks up or gives me the BSOD except for the first boot in the morning. It's rock solid except for this.
I may just suck it up and order some new memory and/or a new PSU.
February 21, 2010 10:19:02 AM

With this issue we're restricted to one test per day since it only happens on the first boot.
This morning I did a very low tech experiment. Some folks believe that the PSU is the problem and on a cold boot things are just too cold and there's not enough power getting to the components. I don't know if this proves anything but here's what I did. I booted to the bios window and let it sit for 15min or so to let electricity flow through all the components and warm them up. Once the air coming out the back was warm and the case felt room temperature I proceeded to boot to Windows. No go. BSOD. However, it appeared to get further. Not that this means anything but I actually saw my desktop background and a little window that said playing login sound (even though I didn't hear it) before it went to the BSOD.
Everyday it stops at a different process but today I seem to have made it to swaidi.sys. This appears to be a audio system file hence locking up on the login sound. However it stops at random processes each day. But for the time being maybe I'll disable my on board sound tomorrow morning. Any thoughts?
Because this happens only on the first boot of everyday could it have to do with the BIOS or CMOS date of some kind?
I'm ordering some new memory today.
February 25, 2010 10:20:58 PM

SOLVED


My issues has been solved. It was a memory issue. G.Skill doesn't play nice with the other kids on the playground. Thankfully Gigabyte noticed the incompatibility and released a bios update at the beginning of the month. Applying this update completely solved the issue. Under notes for this update Gigabyte notes memory compatibility issues.

Prior to the bios update I ran memtest86 and every test was a failure. This was a red flag that it wasn't actually the memory that was the issue but rather the memory controller of the motherboard. Post bios update memtest finds no issue what so ever.

benjic you're in luck, apply the new F7 update to your motherboard and you should be all set. As for the original poster, I have no idea if your motherboard has had any updates for this issue.

I'm now running a rock solid system in Windows 7.
February 25, 2010 11:50:24 PM

Excellent news!

I was going to wait to see the results of the new memory, but if there's an update that will fix it I may give that a try before worrying about replacing the RAM. For my board (Gigabyte X58A-UD7) there's no F7 update listed yet, but after looking the F4 update does claim (Enhanced Memory capability) so I might give that a try.

In the next few days I'll work out exactly what my BIOS is currently and update if necessary to see if this resolves the problem or whether I still have to wait for my boards next update to fix it. I'll post the results when I get around to it.
Anonymous
a b B Homebuilt system
June 6, 2010 3:13:40 PM


Benjic,...

Since I have the same mobo using XFX 5970 and Dominator GT 1866CL7 I was wondering if you finally found the proper (perhaps a beta) bios or in general if u managed to solve your problem?!
!