Sign in with
Sign up | Sign in
Your question
Solved

Bios only detects primary ssd and optical drive but not storage hdd

Last response: in Storage
Share
January 3, 2012 5:35:38 AM

specs
Mobo: Gigabyte 880ga-ud3h (Rev. 2.2)
CPU: AMD Phenom II 955 BE (3.2Ghz stock)
Ram: Corsair xms3 4x2Gb 1333mhz sticks (8Gb total, now running only 2Gb total)
Storage: OCZ Agility 3 60Gb ssd (sandforce drivers) -/- Western Digital Caviar Black 400gb sata hdd
Graphics: Evga Nvidia GTX 470 SOC
PSU: Corsair Professional Series Gold AX750 750Watt Psu

a few weeks ago, i got a new OCZ Agility 3 60gb ssd and Corsair Carbide series 500r computer case (got myself a Christmas present). i moved my computer to my new case and performed a clean install to set up the ssd as my primary drive, and my older Western Digital 400gb as storage for programs, steam games, and storage of files. prior to re-installing windows 7, i set up bios for ahci and had my ssd in sata port 0 and my hdd in sata port 1. i plugged my optical drive into sata port 4, because ports 4 and 5 were set to "as sata type" in bios to avoid optical problems with ahci. the operating system installed first try no problems and ran flawlessly until i turned it on yesterday and came back to a slow running desktop that wouldn't load anything and eventually hung up. no bsod or error messages and i had to hard restart it.

now it doesnt even want to start the operating system with my hdd attached. i checked bios for recognition and it wouldnt show up. when i took it out and had only the ssd in, it would boot as fast and snappy as before.

i don't know what else to do.
I've tried going down to 1 stick of ram and testing them all, nothing
i tried every sata port configuration i could think of
the drive is spinning up and i tested the sata cable and tried others
tried many different bios settings even setting all sata ports to ide for maximum chance of compatibility
i'm now on a brand new clean install and cannot get this hdd to work
if i do get it to boot with this hdd attached my computer is bogged down at startup and often results in system hang. (still does not recognize hdd)
the ssd works no matter what sata port i move it to

note: this hdd was originally from a raid 0 array with another identical drive that i connected in place to see if it would be recognized and the same issue persisted. i haven't been able to test the hdd in an external enclosure but i see no reason why it shouldn't work if an identical hard drive i know worked weeks before i installed my ssd, does the same thing.

any recommendations are greatly appreciated. if you want pics of components, bios settings, windows, or components i will post them. it just seems so backwards for the older hardware to not work while a brand new ssd i barely have any experience with works no matter what i'm trying.

should have more time later this week to test the hdd in another system or external enclosure. if thats not it, then im dead in the water and at a bad time with the new semester of college coming soon. :( 

thanks in advance
January 3, 2012 6:00:13 AM

also, if it helps, my area has been having some pretty bad brown-outs for two days withing the time of my upgrade. i really dont want to admit it but i dont have my computer on any type of surge protection. really hoping i dont have a faulty Mobo from it, but like i said it's fast and reliable with the hdd out...
m
0
l
January 3, 2012 3:10:08 PM

this morning, i remembered i had another older sata hard drive and wanted to see if it would work just for kicks. also, when i connected it, i disconnected my ssd to make sure it wasnt influencing it.

i connect it and turn on my computer- bios recognizes it

i attemp to boot the old os on it- it boots and blue screens because it was for a different computer

then i shut it down and reconnect my original storage drive - it works too!

i connect my ssd back up - bios recognizes both my ssd and storage hdd

i set my bios settings to the way they were before this happened and try to boot up- i does just like before (i had to format my storage drive though)


the only thing i can think was a suitable reason for the issue, was that bios was hung up on that type of drive and needed something different to break the cycle. whatever the case, glad its fixed
m
0
l
Related resources

Best solution

January 3, 2012 4:01:48 PM

as sata type means that the port 4 and 5 will be working as the port 0-3. to have them working as normal sata (no RAID, no AHCI), you have to set it as IDE.

You may want to have the storage and the optical to 4 and 5 if the hdd was already formatted, because AHCI write some metadata on HDD for proper recognition and may confuse the controller if not present. The optical drive is better there for compatibility reason.

Now that you have reformatted your storage drive, correct AHCI metadat were written on the HDD and that's why it works more reliably. Note that modern SATA optical works as well on AHCI but some programs may have problem to write on them.
Share
January 3, 2012 5:28:00 PM

thanks for your response. i originally had to format my hdd after my first clean install because it came from a raid 0 array, so i did follow procedure for setting it up as AHCI.

Regardless, thanks for a lot of helpful information. some wording in BIOS can be confusing, even after working on 50+ computers (mostly older recycled technology).

I'm putting your post as best answer because in the end it's part of what i had to do to get it working and it's solved, so there's not much reason to keep the thread open
m
0
l
January 3, 2012 5:28:15 PM

Best answer selected by nurakiera.
m
0
l
May 23, 2014 5:44:22 PM

I have this same problem but could not find a solution. Could you guys give me some advice?
m
0
l
!