5850 Crossfire issue

Hello all,

I've just installed 2 5850's into an eVga x58 board. I am really not sure if my crossfire setup is working properly. I've connected the bridges properly. The device manager shows 2 cards properly. However in CCC I only see a single card in all dropdowns. However Crossfire tab is visible and I can enable/disable crossfire. Also in graphics hardware section I can see that second adapter is linked. Let me give you an example to be more specific. If I go to ATI Overdrive there is only a single card in the dropdown. By the way all overdrive options are disabled. Please tell me what's wrong.

Thanks,

Yenal

Primary Adapter
Graphics Card Manufacturer Powered by ATI
Graphics Chipset ATI Radeon HD 5800 Series
Device ID 6899
Vendor 1002

Subsystem ID 0330
Subsystem Vendor ID 1043

Graphics Bus Capability PCI Express 2.0
Maximum Bus Setting PCI Express 2.0 x16

BIOS Version 012.011.000.006
BIOS Part Number 113-C00201-100
BIOS Date 2009/09/25

Memory Size 1024 MB
Memory Type GDDR5

Core Clock in MHz 725 MHz
Memory Clock in MHz 1000 MHz
Total Memory Bandwidth in GByte/s 128.0 GByte/s


Linked Adapter
Graphics Card Manufacturer Powered by ATI
Graphics Chipset ATI Radeon HD 5800 Series
Device ID 6899
Vendor 1002

Subsystem ID 0330
Subsystem Vendor ID 1043

Graphics Bus Capability PCI Express 2.0
Maximum Bus Setting PCI Express 2.0 x16

BIOS Version 012.011.000.006
BIOS Part Number 113-C00201-100
BIOS Date 2009/09/25

Memory Size 1024 MB
Memory Type GDDR5

Core Clock in MHz 725 MHz
Memory Clock in MHz 1000 MHz
Total Memory Bandwidth in GByte/s 128.0 GByte/s
2 answers Last reply
More about 5850 crossfire issue
  1. okay, try use this software:
    http://www.techpowerup.com/gpuz/
    run that and see if your CF is work or not... :)
  2. I don't mean to state the obvious, but have you connected another 2x PCie power cables from your PSU? By the way what PSU are you using? 2X 5850's take some power . . . :??:
Ask a new question

Read More

Radeon Crossfire Graphics