Sign in with
Sign up | Sign in
Your question

Windows delayed write failed

Last response: in Storage
Share
January 4, 2012 3:44:19 PM

Hello,
I have a 500G external HD which I use to store movies, music. shows etc. Since the last two days it is showing error Windows Delayed Write Failed, all data could not be saved etc.
The first time it happened Icould open the sub-folders and play movies in all but one folder. Now cannot open any subfolder, and in properties the subfolders show 0.kb. But the properties in the Drive shows free space 62G out of 466G (file system NTFS). I have scanned for virus with NOD32 and found all to be virus free.
The five folders in the drive, names are intact. I have followed previous threads on this topic and tried to take corrective action but no luck.
Can anyone give some suggestions as I dont want to format and loose all the data in the usb drive. I am using XP serv pack2 and can not follow the computer lingo unless explained clearly. HEEEELP. Thanx
January 4, 2012 4:03:01 PM

evongugg said:
You receive an error message when you save or move documents in Windows XP: "Delayed Write Failed"

http://support.microsoft.com/kb/330174


I receive the error message only when I try to open/defrag/run chkdsk etc, on the external usb drive in question.
Related resources
a c 354 G Storage
January 4, 2012 5:17:17 PM

You can try another USB cable in case the one you have is somehow damaged. You can also download DiskCheckup and check the SMART status of the drive. It's possible it may be failing.

http://www.passmark.com/products/diskcheckup.htm
January 10, 2012 4:43:24 PM

Hawkeye22 said:
You can try another USB cable in case the one you have is somehow damaged. You can also download DiskCheckup and check the SMART status of the drive. It's possible it may be failing.

http://www.passmark.com/products/diskcheckup.htm


Sorry for the late reply. Was out of town(job related).
I tried chkdsk. It gets to 48% fairly quickly then it checks a folder called RECYCLE something like I:\RECYCLE... and then all of a sudden it is 100% checked and everything is ok. But I could'nt find a folder called RECYCLE in the disk and I still can not open any files in the external storage disk.
a c 354 G Storage
January 10, 2012 5:36:49 PM

RECYCLE is a hidden folder on each drive. These folders are represented by the trash can on your desktop.

You may want to try diskcheckup that I wrote about earlier. Also, you can turn off write caching at the expense of a performance hit. Just go into the device manager, right-click your drive and select properties, then check off optimize for quick removal.
January 11, 2012 8:50:00 AM

Hawkeye22 said:
RECYCLE is a hidden folder on each drive. These folders are represented by the trash can on your desktop.

You may want to try diskcheckup that I wrote about earlier. Also, you can turn off write caching at the expense of a performance hit. Just go into the device manager, right-click your drive and select properties, then check off optimize for quick removal.


Hey thanks for the info. Optimize for quick removal checked. SMART diskcheck done. Only the partitions on the laptop
disk showed on the diskcheck Physical Devises Tab. Dont know how to attach result of diskcheck to this mail. The External Drive (although Attached by USB cable) for some reason did not show up on the Physical devises Tab. So I assume that drive could not be checked. The error is still the same.
a c 354 G Storage
January 11, 2012 10:50:30 AM

Optimize for quick removal should only be set on the external drive, not the OS drive. That should eliminate the error as there should be no more write caching on that drive once optimize for quick removal is set.
January 11, 2012 12:26:07 PM

Hawkeye22 said:
Optimize for quick removal should only be set on the external drive, not the OS drive. That should eliminate the error as there should be no more write caching on that drive once optimize for quick removal is set.


Noted. It was done only on the external drive. Just checked back and the OS drive shows write caching can be done.
Opened the external drive. Then tried opening sub folders, get fol message "I:( folder name) is not accessible. The request could not be performed because of an I/O devise error."
a c 354 G Storage
January 11, 2012 3:24:39 PM

I also noticed (in xp) that in the device manager, when the drive is set to optimize for perormance there is anothe check box below this setting that reads enable write caching. You can try unchecking that option. This and optimize for quick removal are the only ways I know to disable write caching on a hard drive.
January 11, 2012 5:02:36 PM

Hawkeye22 said:
I also noticed (in xp) that in the device manager, when the drive is set to optimize for perormance there is anothe check box below this setting that reads enable write caching. You can try unchecking that option. This and optimize for quick removal are the only ways I know to disable write caching on a hard drive.


The option 'Enable write caching' check box is only on the OS drive and none on the external drive. I dont think you want me to disable that.
a c 354 G Storage
January 11, 2012 5:03:44 PM

No, don't disable it on the OS drive.
January 14, 2012 9:36:36 AM

It did'nt work out. Can I try some other suggestion if forthcoming.
a c 354 G Storage
January 16, 2012 11:04:38 AM

Sorry, those are the only ways I know to disable disk caching. Hopefully someone else can shed some light on this.
January 16, 2012 11:49:37 AM

Hawkeye22 said:
Sorry, those are the only ways I know to disable disk caching. Hopefully someone else can shed some light on this.


Hey, thanks a lot. Without your help I couldn't have tried anything. I guess the drive is corrupted beyond repair, so I'll just format and start again. Thanks again for giving me hope.
January 23, 2012 10:08:11 AM

Guys, although none of the above worked for me they were great suggestions and can be safely tried by anyone with similar problems. Thanks and regards.
a c 354 G Storage
January 23, 2012 10:41:57 AM

Good luck to you. Sorry it didn't work for you.
March 5, 2014 10:20:40 AM

For what it's worth, in microsoft's solution here: http://support.microsoft.com/kb/330174 by paying attention to the "Cause" section, I realized the reason I may have been getting the "Delayed Write Failure" warning could be the result of trying to write (copy) files to an external hard drive through a USB hub. By removing the hub and connecting directly to notebook's usb port, I had no further warnings.
!