Sign in with
Sign up | Sign in
Your question

GA-870A-UD3 BIOS Questions

Last response: in Motherboards
Share
August 9, 2010 11:05:46 PM

Gigabyte tech support hasn't responded to me so hopefully I can get some advice here.

I just installed this m/b. WIN XP2 and upgrade to SP3 loaded fine. As far as I can tell everything is running OK.

I loaded the AMD SATA ACHI x86 drivers during the OS loading. No problems there.

In the BIOS, I have the AMD850 controller ports 0 - 3 and 4 - 5 set to ACHI and at 3 Gb/s speed. I have the Gigabyte controller set to IDE. I have the JMicron controller set to ACHI.

I have a Seagate Barracuda SATA 3 GB/s 7200.10 that supports NCQ connected to port 0 of the m/b AMD850 ports. WIN XP is installed on the Seagate drive that is attached to that port.

I connected the eSATA cable from my CM690 case to port 4 of the AM850 m/b ports. Currently nothing attached to that.

Finally, I have two IDE optical drives installed; a Pioneer DVD/RW(ATA/66) and a Toshiba DVD ROM(ATA/33).

I have some BIOS issues.

1. In standard CMOS section, my Seagate HDD is not recognized? It was initially there when I first booted and the AMD controller was set to IDE. It disappeared when I set the AMD controller to ACHI. I tried the Auto thing and it did not do anything.

2. My IDE optical drives are recognized in the above CMOS section but only after I set the Gigabyte controller to IDE mode. However in WIN XP, both these drives are showing up as SCSII devices? Initially, they were shown under the control of the XP IDE controller but that changed when I loaded the Gigabyte SATA drivers from the m/b CD.

It also appears that the bootup sequence is out of sync. I see a splash display that appears to be coming from the Gigabyte controller about no HDD found but the PC still boots fine.


-------------------------------------------------------------------------------
Model Name : GA-870A-UD3(rev. 2.1)
--------------------------
M/B Rev : 2.1
BIOS Ver : F2
Serial No. :
Purchase Dealer : -------------------------------------------------------------------------------

VGA Brand : Biostar Model : 9500GT
CPU Brand : AMD Model : Phenom II 945 Speed : 3000
Operation System : Win XP SP : 3
Memory Brand : G.Skilll Type : DDR3
Memory Size : 8 meg Speed : 1333
Power Supply : 750 W




a c 177 V Motherboard
August 10, 2010 2:11:37 AM

It is entirely normal for the drive to 'disappear' from the standard POST screen when enabling AHCI. When the controller is configured as IDE, the POST polls and recognizes the drives; once in AHCI, a seperate section of the BIOS, technically called the 'option ROM', and commonly called a 'RAID BIOS' takes over the polling, recognition, and initialization. This 'chunk of BIOS' is provided by the controller manufacturer...

If your opticals are working right, I wouldn't worry about them being listed as SCSI controlled - this is mostly due to confusion in the backward compatibilty functions of the controllers, and is of no consequence, either... I have seen a number of problems in the operation of AHCI drives that have been switched from IDE to AHCI, or back, the other way - and primarily with AMDs. haven't had enough solid experiments with folks here to have figured out the culprit, and I don't do AMDs myself, so ??

I was somewhat confused by the SATA designations, as "GSATA2" ports, aka Gigabyte SATA, are jMicrons - all of 'em!

It may just be a BIOS glitch causing the report by the controller hosting the IDE's (but no hard drives) that is causing the 'no drives' message - but, as both of the aux controllers are the same chip, it may be the other, being 'caught' by the AHCI (again, these controllers have their own 'RAID BIOS') activated to get hot-plug on the empty eSATA channels...
m
0
l
August 10, 2010 12:11:58 PM

Thanks for the reply, Billbat! Nice to know the disappearing HDD is normal behavour for a drive on a ACHI configured SATA controller.

I was somewhat confused by the SATA designations, as "GSATA2" ports, aka Gigabyte SATA, are jMicrons - all of 'em!

This is how those two controllers are described in the 870A Gigabyte m/b manual. It refers to the two Gigabyte SATA ports no. 7 and 8 which are mounted on the edge of the m/b at a 90 degree angle as the "GSATA2" ports. It refers to the two rear mounted external eSATA ports as the Jmicron SATA2 ports. I did notice that both controllers use the same Gigabyte SATA driver.

What is confusing is trying to determine what controller is used by the m/b single IDE port. Nothing is mentioned in the m/b manual about that. There are four controllers on this m/b.

The AMD850 Southbridge chipset supports 6 SATA ports via 2 controllers; one for ports 0 - 3 and the other for ports 4 and 5. The controller for ports 0 - 3 supports a "native" IDE mode - I have no clue how that differs from plain IDE - along with ACHI and RAID. The controller for ports 4 and 5 can be configured separately and supports PATA IDE, ACHI, and RAID. The glitch with this chipset is only supports one speed setting for both controllers; 6 GB/s which is supposedly compatiable w/ 3 and 1.5 GB/s drives or 3 GB/s compatiable with 1..5 GB/s. I have no clue as why this was done since I would think the one 6 GB/s setting would have been enough?

The Gigabyte aka JMicron controllers support IDE, ACHI, and RAID at 3 and 1.5 GB/s.

m
0
l
Related resources
August 10, 2010 1:48:19 PM

I have the 870A-UD3 v2.0 and installed two Seagate SATA2-1 TB drives, one is a three-platter and the other a "two". The 3-platter drive has Win7Prox64 installed while the 2-platter is just for storage, but I can't get the OS to read the "twofer". All the settings for the drives in the BIOS are set to default and it shows up on POST, but not in Win7. I have partitions for Win7x32 and XPsp3 on the OS drive, but they don't see the "twofer" either, so any help would be greatly appreciated!!!
m
0
l
August 10, 2010 1:52:06 PM

And yes I tried simply booting to the new 2-platter drive to format it and the BIOS didn't see it at all, trying to boot to the CD/DVD drive instead!
m
0
l
a c 177 V Motherboard
August 10, 2010 2:31:41 PM

The main controller set is split up (Intel southbridges and hubs are the same) as the first four ports have a compatibility mode which makes 'em look like the older IDE controllers, which allowed two ports of two drives each (master and slave). Native mode should always be enabled, unless you are one of the eight people who have win ME running (I used to say seven people, but now I are one - got an old notebook from someone for recycling, and it actually runs ME - I didn't even know what the splash screen looked like - had never seen one!); it simply turns on interrupt sharing, and ME was the last operating system that did not support sharing...

Devices are operated, inside an operating system/BIOS by something called an 'interrupt mechanism'. Interrupts, to the system, are kind of like a little kid tugging on ma's skirt - "Ma, can I have a candy bar?"; "Ma, can I have a coloring book?"; "Ma, look at the funny man!" :??:  Every time you hit a key on your keyboard, the hook-up generates an interrupt, telling the system "Hey, this is important - I've got a keystroke to process!" The BIOS/operating system have a set-up to then do what the interrupt requires - handle a keystroke, read a track from disk, whatever... Obviously, the interrupt mechanism has to 'stack up' the interrupts; it can't simply do 'this' while negecting 'that', say, 'ignoring' your keystrokes - they all have to be taken care of, mostly by the DPC (deferred procedure call) stack, which you can read about here:
http://www.thesycon.de/deu/latency_check.shtml

Anyway, interrupts are a hardware mechanism - they are operated by an electrical logic signal, they want to be dedicated to one piece of hardware, and have to be prioritized. Back in the old days [:bilbat:6] , when we were carrying our laptops (and even that was a misnomer - unless you weighed at least three hundred pounds, no way anyone had enough 'lap' for one!) to work on the backs of dinosaurs, every time you wanted to hook up some new piece of crap to your computer, you had to go through a pissy process of locating a new interrupt: let's see, this nifty new MIDI card can use 3, 4, 7, 9, 11, or 12 - my main com port is using 4, the second com and modem are already sharing 3, and neither one is happy about it, my printer has 7, and I think my mouse card uses 11, or is it 9? Hopefully, you kept a running list of "who's got what", or you were screwed! Also, these were set by putting little pin jumpers on board headers, and if you had to select an address range for memory-mapped I/O as well, you might have to get a dozen jumper positions correct, or you were also screwed!

This led to, to paraphrase (Lincoln, I think?), to the situation: "You can have some of your crap working all of the time, and you can have all of your crap working some of the time, but you can never have all of your crap working all of the time! (Come to think of it, in all these years, that hasn't really changed all that much! [:bilbat:9] )

As people were adding more and more stuff to their systems, this got more demanding and complex, and was a stumbling block for sales - people got hesitant to buy additions, as they knew what a hassle getting it to work would be... MS came up with 'plug & play (which was so unreliable, at the time, that we all used to jokingly call it 'plug & pray!'), which allowed most of these parameter selections to be set up in software. As the number of devices kept growing, it also became critical for the interrupt mechanism to learn how to share interrupts, so that a single hardware signal line could service a number of devices. This interrupt sharing feature was introduced in Xp, and was one of the reasons for its success and popularity.

So native mode simply refers to an OS whose interrupt sharing ability is 'native' to the OS - and always wants to be 'Enabled'...

Quote:
What is confusing is trying to determine what controller is used by the m/b single IDE port. Nothing is mentioned in the m/b manual about that.

If you'll look at the center right portion of the system's block diagram, on page eight of your manual, you will see that the IDE/PATA duties are done by what they call the 'Gigabyte SATA2', but, so far as I know, is always just a jMicron chip. I would guess that it's a JMB363, as you have a 362 running the eSATA ports, and jMicrons work in families - the 363 is a 362 with a single PATA host, the 366 is a 362 with a pair of PATA hosts, and is hardly ever seen...

Quote:
This is how those two controllers are described in the 870A Gigabyte m/b manual.

The manual is exactly what confused me! This is sort of a 'middle generation' board; GB transitioned some documentation over a couple years. Your board is new enough to have the "MB Intelligent Tweaker(M.I.T.)" as the first BIOS entry in the manual (early boards had it last...), but they apparently hadn't yet gotten to the point of standardizing the description of the eSATA poerts as, well, eSATA! In late manuals, they'll simply call it the 'eSATA controller' (still, just a jMicron!) - took me a bit to figure out which was which [:fixitbil:9]
m
0
l
August 25, 2010 9:32:11 PM

Just following up...I disconnected the other drives but for one optical DVD and the 2-platter SATA2. Then I booted to my win7-64 install disc, it recognized the one drive and installed to it. When I put everything together it recognized all my drives on startup and launched right into Win7 on the new drive. I put both drives on the GSATA ports with no issues, but I do wonder if this board will recognize any other eSata or Sata3 drives later, I hope I won't have to install Windows on every drive! The other thing I don't understand is the WEI rating, it gave this Seagate 2-platter drive a 5.9 and held back my 7+ rating! Isn't that a bit low for a SATA2 drive?
m
0
l
a c 716 V Motherboard
August 25, 2010 9:42:58 PM

@Tripperdude - you should start a new post; it gets confusing otherwise.
m
0
l
August 26, 2010 2:35:02 AM

jaquith said:
@Tripperdude - you should start a new post; it gets confusing otherwise.


Dude, it's been two weeks since anyone has posted to this thread! Who cares! That's why I called it a "follow-up", it was only a rhetorical reply!
m
0
l
a c 716 V Motherboard
August 26, 2010 4:47:35 AM

@tripperdude - the primary reason is for "your benefit" OP responses trigger notification.
m
0
l
August 26, 2010 1:27:10 PM

jaquith said:
@tripperdude - the primary reason is for "your benefit" OP responses trigger notification.

In the future I would appreciate you refrain from telling me how to post questions and topics. Chances are very good I've been posting to DIY forums and Usenet long before your 440BX ever needed diapers.
m
0
l
August 26, 2010 11:05:52 PM

I have another problem that has surfaced. I have had a real hard time finding any HHD diagnostics that will read my Seagate 7200.10 Baracuda SATA 3 GB/s drive. HDDTune Pro didn't work nor did many others. I finally downloaded Everest as a trial ver. and although it did not recognize my 870A-UD3 m/b it was able to read most of the info. It also was able to read my drive parameters also but no SMART info?

I never had any problems with SMART with this HDD on my old MSI AMD 939 board. But nothing so far I have tried will show SMART info on this Gigabtye board. I have SMART enable in the BIOS. Also my temp sensor for the drive is not being display but that could be related to the SMART issue.

Anyone else having trouble with SMART when using the ATI 6 Gb/s controller in AHCI mode?
m
0
l
a c 716 V Motherboard
August 26, 2010 11:42:40 PM

Do what you will but I've had more issues caused by SMART monitoring than it's helped; higher temps + noise. Monitoring on a server makes sense... Any failures I've had were unexpected and far between and in a protected RAID. Mission critical HDDs are redundant {RAID} and replaced + destroyed after 5 years.

Seatools - http://www.seagate.com/ww/v/index.jsp?locale=en-US&name...
Passmark - http://www.passmark.com/products/diskcheckup.htm
m
0
l
August 26, 2010 11:53:26 PM

I tried the latest ver. of Seatools. It would not even recognize the drive at least in WinDose. I might try the bootable DOS ver. ..... Again none of the current Windose utilities are up to date with the ATI controller.
m
0
l
August 27, 2010 2:05:57 AM

Disable ACHI, stick to IDE mode

(PS: SMART mode works, or at least it did back in the 32-bit daze. AM3 and 64-bit is all new to me, but I have a feeling the same principals still apply!)
m
0
l
August 27, 2010 2:22:34 AM

DonZ62 said:
I tried the latest ver. of Seatools. It would not even recognize the drive at least in WinDose. I might try the bootable DOS ver. ..... Again none of the current Windose utilities are up to date with the ATI controller.


PPS: Try PassMark DiskCheckup, download the free version here...

http://www.passmark.com/products/diskcheckup.htm

You're Welcome! :D 
m
0
l
September 3, 2010 8:04:03 PM

Per Passmark's web site:

System requirementsA hard drive that supports SMART, plus compatible drivers. Most recent hard drives (SATA/USB/FireWire) are OK but drives connected via SCSI or hardware RAID are not supported. Drives configured as software RAID (dynamic disks) via Windows Disk Management will also work.

I think the problem is that the AMD850 chipset ATI driver is using SCSI for it's controller when in AHCI mode and none of the current utilities have been updated for it.

m
0
l
!