Sign in with
Sign up | Sign in
Your question

Packard Bell Easy Note Argo C2

Last response: in CPUs
Share
Anonymous
a b à CPUs
March 20, 2010 10:07:38 AM

Hello,
Initailly when I switched PC on , PC said only 2.5 Mins Battery Left. Before I could get PSU connected the PC switched off.

When PSU connected tried to power up PC Battery Charging Light flashed 8 Times and PC failed to start. Repeated tries same thing happens PC will not start up, nor is there any indication that Battery is charging!
a b à CPUs
March 20, 2010 10:38:07 AM

The first and most obvious thing to check would be that your charger is definitely working. Other than that it could be your battery. Just try removing your battery and reseating it too. On most laptops there is a way to drain any residual charge from the battery and go from there. It usually involves holding down the power button with the battery removed and then inserting the battery again or something along those lines. I'll have to have a look around for your specific laptop though. Try the obvious first :) 
March 20, 2010 5:07:07 PM

Packed In Hell... throw it out the window and start over... if you paid real money for it you've been screwed!
Anonymous
a b à CPUs
March 20, 2010 8:46:01 PM

moody89 said:
The first and most obvious thing to check would be that your charger is definitely working. Other than that it could be your battery. Just try removing your battery and reseating it too. On most laptops there is a way to drain any residual charge from the battery and go from there. It usually involves holding down the power button with the battery removed and then inserting the battery again or something along those lines. I'll have to have a look around for your specific laptop though. Try the obvious first :) 


The AC PSU has been checked out, 235V AC input and 14.35V DC Out.

Battery checked out as you suggested but no change. Left Computer for 2 hours and still no change .

It is somewhat omnious that the flashing orange LED (Battery Charging Indicator) repeats the 8 Flashes everytime I endeavour to start the PC.
These 8 Flashes must be a code for something?

Have sent an E-mail to Packard Bell asking their opinion however I dont hold out much hope of a response from them as their Customer Service is pretty poor .

Thanks for your inputs all the same

Znord737


!