Sign in with
Sign up | Sign in
Your question

Sata hdds one of them detected 2 are not.

Tags:
  • Hard Drives
  • Western Digital
  • SATA
  • Storage
Last response: in Storage
Share
January 7, 2012 9:38:06 AM

Sigh... ridiculous problem. I have 3 Sata drives.
1st is an older WD 80 gig that has started to fail. (Windows 7 installed)
2nd is Seagate 80 gig that is refurbished and just purchased. (formatted clean)
3rd is Seagate 450 that by all accounts is good just switched from an old system to this one (formatted clean)

motherboard is an Asus M4a79xtd-EVO

My Bios ONLY detects the WD. It detects the WD in every Sata port. It detects the WD with any of my Sata cords.

Now, in windows the other two do not show up, however, if i scan disk drives for hardware changes, OR rescan disks in disk management the two seagates show up, but later disapear again. A restart at this point and they still don't show up in bios. (again, tried every cord/port/reconfiguration of the hdds ie removing all but one, so on and so forth.)

I try a fresh install with Win 7 and again they do not show up, however when loading drivers from the working WD i'm able to get the Seagates to show up, but windows says they cannot be booted from and to check my controller to see if they are enabled. Yes the bios options are set to auto detect them and Sata IS enabled.

I've tried a number of things and followed as much advice from similar topics as i could but this seems to be fairly unique and i've yet to find an exact answer no luck... i want to get rid of the WD and do a fresh install on one of the other two SATAs so i can actually use my comp (the WD will absolutely not let me load any intensive program and will freeze up during any large amount of activity.)

More about : sata hdds detected

January 8, 2012 11:54:04 AM

couple of things.. during boot up marvell adapter version 88esata whatever pops up says no hard disk detected... i've uninstalled/deleted everything related to those drivers (to see if the controller is the issue with non-detection) so not sure why thats still showing up during boot. regardless the WD is still bootable. the other two simply aren't detected in bios... considering getting a sata-usb or sata-ide adapter at this point... :/ 
m
0
l
a c 265 G Storage
January 8, 2012 1:44:36 PM

Your Marvell controller only runs 1 internal port and the esata http://www.asus.com/Motherboards/AMD_AM3/M4A79XTD_EVO/#... to disable the message you will have to disable the controller in BIOS. The 6 other ports are all native on the 750 south bridge and you have proven that they work with one of the drives. That leaves me to think that the problem is with the drives or the connection to them power or data.
m
0
l
Related resources
January 8, 2012 2:21:56 PM

definitely not the power tried multiple connections to each drive. and as i mentioned tried every sata cord/port with the one drive all working. really questionable that the drives are bad. at least i'd like to believe i wouldn't be sold a refurbished drive that is useless from the get go.. bleh.
m
0
l
a c 265 G Storage
January 8, 2012 8:15:45 PM

It happens, can you try them in a different computer?
m
0
l
January 12, 2012 10:22:02 PM

yes tried them on another older build and they show up immediately.. turns out there is a possible seagate issue with my board recommends downloading new firmware and such... i've done this.. no result... /glares
m
0
l
a c 265 G Storage
January 12, 2012 11:15:00 PM

That is rather unbelievable, I have had hard drives from WD, Seagate and some older Maxtor and IBM drives and never had any issues. Your board still under warranty?
m
0
l
January 13, 2012 2:42:09 PM

I sent in a ticket to asus, but no i don't think its under warranty... le sigh.
m
0
l
!