MA785GM-US2H super slow in post and windows 7 install

Hi,

Just completed my first proper build from scratch. My motherboard is the Gigabyte MA785GM-US2H rev 1.1. However in POST the system is so slow and it took seriously long to install windows 7. Now its running its fine in windows 7, but in POST it really lags still.

I have heard remedies are to:

Disable the floppy
Switch to AHCI mode instead of IDE

However neither has worked. There may be more options I am missing, if so pointers would be helpful here.

In AHCI post takes even longer and it goes into a 'scanning AHCI drices'. This goes on for ages.

I have a SATA DVD drive and hard drive. Both are less than a year old. I have no IDE devices. Also I have the latest BIOS version (12a).

I would really appreciate help on this. To be honest I don't really know what AHCI is or why this is happening really.

Thanks
5 answers Last reply
More about ma785gm us2h super slow post windows install
  1. What is your Boot priority? <- try changing to your primary HDD/SSD.

    What devices (SSD/HDD/GPU/etc) do you have connected to the MOBO?

    What "other" changes have you made to the BIOS?
  2. My boot priority at the moment is
    HDD
    CD
    USB

    My connected devices are
    GPU: Sapphire HD 4670 Ultimate
    1 SATA DVD DRIVE - Samsung S223Q
    1 SATA HARD DRIVE - Samsung F2 EcoGreen HD502HI
    2 x 2 GB RAM DDR2 1066MHz (running at 800 MHz though) - Corsair
    CPU: AMD Atlhon X2 260 3.2 GHz
    Netgear PCI Wireless card


    I only built the computer yesterday so the motherboard BIOS was updated to the newest and then set to 'choose bess settings' as suggested in the maunual.

    I then turned off the floppy drive support and changed the boot order. Originally the DVD drive was first and it took longer so I put HDD first.
  3. So I am correct, the only BIO settings (2) that you've changed: 1. Load Optimized Settings, (2) Modified your boot order, and nothing else...right?

    If so:
    1] shutdown your rig and disconnect, unplug SATA cable only to the MOBO, the second HDD "1 SATA HARD DRIVE - Samsung F2 EcoGreen HD502HI" which I assume is not in RAID.
    2] remove the PCI card - Netgear PCI Wireless card

    If the problem is fixed first add the second HDD, restart test, then last the Netgear.

    We'll address the DDR next - please post the exact part number (needed for timings).
  4. jaquith said:
    So I am correct, the only BIO settings (2) that you've changed: 1. Load Optimized Settings, (2) Modified your boot order, and nothing else...right?

    If so:
    1] shutdown your rig and disconnect, unplug SATA cable only to the MOBO, the second HDD "1 SATA HARD DRIVE - Samsung F2 EcoGreen HD502HI" which I assume is not in RAID.
    2] remove the PCI card - Netgear PCI Wireless card

    If the problem is fixed first add the second HDD, restart test, then last the Netgear.

    We'll address the DDR next - please post the exact part number (needed for timings).


    I think the problem is to to with the hard disk drive. In AHCI mode sometimes it takes ages to scan the connected drives. The DVD is always found but the hard drive is sometimes not found, and if it is windows crashes when it is loading.

    Is it possible a hard drive is incompatible with AHCI mode?

    If I change back to IDE mode then windows loads fine.

    Do I need to get a new hard drive?

    Thanks
  5. Anonymous said:
    I think the problem is to to with the hard disk drive. In AHCI mode sometimes it takes ages to scan the connected drives. The DVD is always found but the hard drive is sometimes not found, and if it is windows crashes when it is loading.

    Is it possible a hard drive is incompatible with AHCI mode?

    If I change back to IDE mode then windows loads fine.

    Do I need to get a new hard drive?

    Thanks


    First, assuming you have your HDD in SATA2_0 - SATA2_3 Enable -> "Native Mode", keep the AHCI setting, and Enable SMART in the BIOS.

    Before getting any new HDD, AHCI is only marginally faster if not the same with your 5400 rpm HDD, and if you subsequently changed in BIOS IDE <=> AHCI you might want to uninstall in the Device Manager the HDD driver, restart and they'll automatically reinstall the HDD driver; sometimes the registry doesn't correctly set AHCI. However, since you described the lag in BIOS that procedure probably isn't needed.

    Otherwise, if your system runs fine in IDE Mode you'll be fine. I did not see any firmware for your HDD.

    Samsung specs - http://www.samsung.com/global/business/hdd/productmodel.do?group=72&type=94&subtype=98&model_cd=439&dType=G&mType=SW&tab=down&ppmi=1219
Ask a new question

Read More

Gigabyte Windows 7 Motherboards