Sign in with
Sign up | Sign in
Your question

Asus m2n68-am & Sapphire HD5830

Last response: in Motherboards
Share
August 14, 2010 1:44:04 AM

Hi All,
I need some help please.
I'm running an Asus m2n68-am Plus mobo with 4 gig ram,Win 7 64 Ultimate

I'm trying to install a Sapphire HD5830 Game Edition graphics card, but I can't get the system to recognize it.
The card is connected and whirring away so i have to assume it's power is hooked up correctly ?

I have tried uninstalling the onboard graphics from device manager and everytime I reboot it simply reinstalls itself
Any ideas anyone ?
a b Ĉ ASUS
a c 135 V Motherboard
August 14, 2010 12:05:18 PM

Hello and welcome to the forums
There should be an option in the BIOS to disable the onboard card too.
Also do you install the driver for 5850 ? if so does it install fine or gives errors ?
August 14, 2010 8:50:02 PM

Hi,
Thanks for the welcome :) 
The only option I can see in the bios is under the "Southbridge Configuration" and it allows for the priority order of the Primary Graphics Adaptor as PCIE-PCI-IGP or IGP-PCI-PCIE. I can see a function in the bios to disable and I can't find anything on the Asus sites that refer to it either.

As for the drivers, the program installs fine (so it says) but then I cant access the Catalyst configuration or any other part of it ... So I have to assume there's an error somewhere.

Would it pay for me to try doing it from the (actual) administrator account ?

Cheers
Related resources
a b Ĉ ASUS
a c 135 V Motherboard
August 14, 2010 9:24:51 PM

Does it give you any error when you want to access catalyst control center ?
Also try updating your BIOS to the latest version and check again if you can disable the on-board VGA from control panel or not
August 14, 2010 11:37:33 PM

At this stage i can't find a way (via a bios updater) to update the bios, and asus seems to give me conflicting info on how to do it manually. Also, no, the catalyst system is not working. I can't access it at all it seems
August 19, 2010 8:38:49 PM

Hi Maziar,
there's no option that I can find to set the vga priority other than the previously mentioned configuration under the Southbridge configuration.

My card does have "PCI-E Overclocking" listed in the bios, which is currently set to AUTO
Could that be making a difference ?
Otherwise I can can it to manual but if I do that, what frequency should I set ?
It has the options of 100mhz 101mhz 102mhz etc upto 108mhz

Thanx for all the help so far, I really appreciate it
a b Ĉ ASUS
a c 135 V Motherboard
August 20, 2010 8:31:48 AM

No,let it be Auto,there is no need to change it.
You mentioned that under "Southbridge Configuration" it allows for the priority order of the Primary VGA,right ? make sure its set to "PCIE-PCI-IGP"
August 20, 2010 8:26:59 PM

Ok, no problem
The priorities are definetly set to that
I have also loaded the bios optimized defaults and am going to format the system and do a clean install and hope like hell that fixes it
a b Ĉ ASUS
a c 135 V Motherboard
August 21, 2010 6:39:18 AM

I hope so,let me know how it goes
August 21, 2010 9:10:20 PM

Sadly Maziar, It's made no difference
My best course of action I think is to take the system back to the manufacturer or give up entirely on trying to u/g
Thank you for your help :D 
a b Ĉ ASUS
a c 135 V Motherboard
August 22, 2010 7:09:27 AM

hmm,then maybe your motherboard is defective, its still under warranty right ?
April 4, 2011 9:43:54 PM

Board is not defective. This is a common problem with this MoBo. I too am having the same problem, as well as many others in multiple forums. The short and sweet is there isn't support to completely disable the onboard graphics. I have done many of the same things in the instructions. Change the vga priority to PCIe-PCI-IGP; allow bios/os to controll Plug n Play for non-startup items; update bios; disable/uninstall onboard graphics through Device Manager...Nothing seems to get Dedicated Graphics cards noticed by either the bios or the OS. There are no jumpers to switch which adapter you want to use, yadda yadda yadda. I have tried 5 different video cards, reinstalls, mounting, unmounting, ect, and still can't get video through a graphics card (either PCIe or PCI). Seems odd that a MoBo that supports dedicated grphics cards has no support/troubleshoot to get these working in the last year this board has been out. I even went so far as to get an ASUS GeForce GTX460 1028mb thinking that ASUS could "talk" to ASUS with no positive conclusion. The computer boots just fine reguardless of which vga you are plugged in to, however, only the onboard VGA port will acctually display.
!