Sign in with
Sign up | Sign in
Your question
Closed

Sound Blaster Audigy 2 zs

Last response: in Components
Share
March 23, 2010 9:22:38 AM

Hey guys,

I recently Upgraded from Windows Xp to Windows 7 x64 bit. My sound card (Sound Blaster Audigy 2 ZS works fine except when
i go into my device manager. It sais missing driver for (Creative Game Game Port). A lot of people have been
complaining about the exact same thing. Did creative drop support for their older hardware???

More about : sound blaster audigy

March 23, 2010 9:29:21 AM

P.S. I hate the fact that I can't seem to things without asking for help lol
March 23, 2010 3:01:08 PM

can find the latest drivers here
http://support.creative.com/Products/ProductDetails.asp...

The game port on that card was a serial port that went in one of your expansion slots and was connected to the card by a ribbon cable. Unless you actually plan to use the serial port I wouldn't worry about it.
Related resources
March 23, 2010 10:14:42 PM

Im running Win7 x64 with the Audigy 2 ZS, all the drivers from creative install fine including the game port.

 RODFAQ_4915,VARSET=CategoryID:1" rel="nofollow" target="_blank">http://support.creative.com/Products/ProductDetails.asp...

The only error that i seem to get is when i click on the speaker icon on the mixer to bring up the speaker properties which reads:
" Windows has detected that the audio enhancement for the following device is causing problems:
Speakers(Creative SB Audigy 2 ZS (WDM))
Would you like to disable driver enhancements for this device? Yes/No "

I have not gotten any problems with selecting "No" so far on mine.
March 25, 2010 10:13:51 AM

Yeah i download those exact drivers and i still get the same issue with the game port.

O well i guess im going on board, I can't stand the blue Screen crashes from it.
July 4, 2011 4:39:04 AM

It says, in the details of the driver download, on Creatives website that known issues for this driver include unsupported gameport in Windows 7, Vista and XP 64bit. I guess they figure no one is really going to use the serial game port anyway these days. I just disabled the gameport in the device manager and I have had no m ore issues. Hope this helps somebody.
July 4, 2011 12:40:21 PM

This topic has been closed by Mousemonkey
!