Sign in with
Sign up | Sign in
Your question

How to upload bios without processor

Last response: in Motherboards
Share
August 14, 2010 8:26:53 AM

Hi
I have bought an ASUS P7P55D-E Premium motherboard and a core I7 875k cpu - I cant even start the Bios to have a look - only a red light on the motherboard telling me something is not right with the cpu. Everything else starts, fans, harddisks and so on, but not the bios. And the cpu seems to fit right.

I have an idea that it might be because the bios is too old and therefor needs updgraing.

I havent got another older LGA 1156 cpu and have no possibility getting one but are stuck with the new one

Is there a way to upgrade the bios without cpu or what else can I do?

More about : upload bios processor

a b à CPUs
a b V Motherboard
August 14, 2010 8:32:00 AM

nope.

you need to have a working CPU to update the BIOS (without a CPU, the system cant really do anything).

i doubt it would be a BIOS issue though, since the 875k should work in any 1156 board without an update. you could try borrowing a CPU from someone else, but i would be more inclined to believe either the CPU or Mobo is faulty.
August 14, 2010 8:40:03 AM

Thanks for the quick answer - thats what I feared the answer would be.

Its not easy to find someone who want to lend you an older lga 1156 processor - most people I know have older cpu's.

And it is weird that everything else seems to work on the Mobo. Only this red light telling me something is wrong with the processor - not what it could be.

Well I have to talk to the shops -
Related resources
a b à CPUs
a b V Motherboard
August 14, 2010 8:47:53 AM

have you tried reseating the CPU?

and have you done a double check that that the cables are connected? specifically the 24 pin mobo connector and the 6/8 pin mobo connector?
August 14, 2010 9:17:15 AM

Hi again - you are wonderfull - went through all the connections and found that the sloppy 6/8 pin connector needed a little twisting - and suddenly it worked!! :-)

Thank you very much for a brillant help !
a b à CPUs
a b V Motherboard
August 14, 2010 9:34:37 AM

lol, no problem. glad you got it fixed.
!