Sign in with
Sign up | Sign in
Your question

Newly upgraded homebuild system giving poor performance

Last response: in Systems
Share
January 18, 2010 1:47:51 AM

Every game I throw at my system it runs it perfectly with settings maxed except for Stalker Call of Prypiat. When I put the setting on ultra(dx 10) I get an average
of 15 fps. Which is terrible, I know this game isn't optimized well but hell, what kind of a system do they think people have?

My specs are
i7 920 @ 2.66
12gb ddr3 1600mhz ram
GTX 295

Now here's the kicker. My girlfriends gaming laptop can run this game with the same settings (ultra dx10) and gets 60fps (that's the average fps, I **** my pants)

Her specs are
Core 2 duo @ 2.0
4gb ddr2 800mhz
GTX 260m

I am running the latest nVidia drivers (I have tried uninstalling and using several older versions) And I just had my OS reinstalled so there is no problems with that.
I also tried uninstalling the game and it is fully updated.

Temps are 55-61 CPU and low 80s GPU. I have also talked to other people who have the same setup as me (i7 gtx295) and get flawless performance with the game.

I don't know if this is the right forum for this to be in but I didn't know where else it would go.
January 18, 2010 2:53:58 AM

What is your power supply ?
Related resources
January 18, 2010 3:55:07 AM

I'm sure the laptop has a lower resolution than what you're using :D . Anyway, I'd say driver problem. Could also be a faulty PSU just not supplying enough power. Any issues in Crysis?
January 18, 2010 3:59:56 AM

I ran the game at 1650 by 1080 just on my computer and on the laptop. Everything was exactly the same. I have tried 3 older drivers with the same performance.

Crysis runs in the high 40s on gamer.
January 18, 2010 6:33:10 PM

Defective video card perhaps? Run some benchmarks and see if there is anything that would indicate that your only running on one GPU rather than two.
January 21, 2010 6:13:12 PM

So I just installed windows 7 64bit and have everything updated, reinstalled the game and still only get 20 fps max.

My brother just got a new system, also an i7 6gb ram, but he has a 5850 he gets a minimum of 100fps, and an average of 300fps.

This is just crazy.
January 21, 2010 6:45:05 PM

J Coffey said:
So I just installed windows 7 64bit and have everything updated, reinstalled the game and still only get 20 fps max.

My brother just got a new system, also an i7 6gb ram, but he has a 5850 he gets a minimum of 100fps, and an average of 300fps.

This is just crazy.


That's sounding a lot like an issue with your card. You should try swapping cards with your brother to see what happens, might help you isolate the issue. If the game runs flawlessly with his 5850 in your system, or if it runs like junk with your 295 in his, then it's likely the card. If it runs well with your 295 in his system, then you'll know the issue is with something else.
January 22, 2010 5:15:10 PM

I took Restatement's advice and tried out my video card in my brothers system, it got 300fps. So it's not my card.

I don't understand how it could be any other part of my system if I can run other games at max settings. Crysis runs just as fast as any of the benchmarks I have looked at for my card.

So with every other game running as fast as it should be how could it be the rest of my system? It just doesn't make sense.
January 22, 2010 5:36:51 PM

J Coffey said:
I took Restatement's advice and tried out my video card in my brothers system, it got 300fps. So it's not my card.

I don't understand how it could be any other part of my system if I can run other games at max settings. Crysis runs just as fast as any of the benchmarks I have looked at for my card.

So with every other game running as fast as it should be how could it be the rest of my system? It just doesn't make sense.


Did you try his card in your system?

A quick google search did not turn up other reports of weird performance on STALKER with the 295 - there's got to be something causing this, it just isn't making sense that everything else is running flawlessly, while this game runs like molasses.

What kind of performance do you get when you drop the game's settings?
January 23, 2010 7:02:45 PM

The performance goes up slightly when I drop the settings. Everything on the lowest settings gives me 70FPS, which is nowhere near the 300 on max my brother gets.

Tonight I will try his card in my system and report back.
!