Sign in with
Sign up | Sign in
Your question

[Solved] New Motherboard, Existing Win 7, Unable to Repair

Last response: in Systems
Share
January 18, 2010 1:53:44 AM

So here's the situation ...

I've a homebuilt system that is about two years old.

The setup was as follows at the start of my trial ...

* Intel Core 2 Duo E6750 Conroe 2.66GHz
* GIGABYTE GA-P35-DS3L
* EVGA 256-P2-N761-AR GeForce 8600 GTS 256MB
* Western Digital Caviar Blue 320GB (x2)
* a
* 2x2GB G-Skill DDR2 1066
* Antec NeoPower 500W

I upgraded my Windows XP Pro installation to Windows 7 Professional in October. Since then, I've had the occasional BSOD, but nothing too heartbreaking. However, in the last week or so, these were occurring about once a day. And so, I decided to investigate. At first, it appeared that the only driver seriously out of date was the HD audio on the motherboard. So I updated it. Then I started to wonder if perhaps the BIOS on my motherboard was out-of-date. Finding that my BIOS version was F7 and the latest was F9, I attempted to flash the BIOS on Saturday morning. This completed without issue, so I rebooted.

From that point on, I had no display. I thought that perhaps the BIOS had reverted and needed a PCI video card, so I tried an older model I had. No dice. There were also no beeps.

If I removed the memory, there were beeps, long and continuous. But once the memory was replaced, nothing but darkness and silence.

And so, I decided to go to Fry's. I had considered upgrading my power supply earlier, and since the power supply could've been a culprit (based on things I've read in this forum), I picked up the following:

* Antec Earthwatts 650

Also, buoyed by reading something this morning about how one could possibly reinstall a motherboard underneath a Windows 7 install, I picked up a new motherboard as well as a just in case:

* Gigabyte GA-EP43-UD3L

The GA-EP43-UD3L appeared to be remarkably similar in design to the GA-P35-DS3L.

So I figured I would transplant the PSU, and if that solved the issue, I'd return the mobo unopened.

Well, here I am a couple of hours later, with the new PSU installed as well as a new mobo installed.

I have a display now and I can access the new motherboard's BIOS. However, Windows 7 will not boot.

What I have done:
* Attempted to boot to the installed OS. This presents me with "Windows is loading files" and advises that I can use "Startup Repair" or boot normally. Booting normally will sometimes get the start of the Windows logo screen, but then reboots. Selecting "Startup Repair" sends me back to Windows Error Recovery and the option of repeating "Startup Repair." Oddly, one last time I selected "Startup Repair", it gave me a loading progress bar and now a white arrow that I can move with the mouse, but nothing else. Subsequent selections have only made the screen go dark and Windows Error Recovery comes back.

* Attempted to boot from a "System Repair Disc" made on my wife's Windows 7 (64-bit) machine. This presents me with "Windows is loading files" (the bar grows slower, of course). This gives me the Windows Error Recovery as well, much like booting to the OS. And the last time I used it, it BSOD'd.

* Attempted to boot from the Windows 7 Upgrade DVD (64-bit). This presents me with "Windows is loading files" twice, but instead of offering a menu of installation options, I am advised by Windows Boot Manager to insert my Windows Installation Disc and repair my computer. Well, isn't that what I'm doing right now? Or is the Upgrade disc somehow hampered and unable to serve as an actual Installation disc?

(The full screen lists a File (\windows\system32\DRIVERS\viaide.sys), Status (0xc0000098), and Info (Windows failed to load because a critical system driver is missing or corrupt).)

So ... what should I do? Borrow a full install disc from some kind soul? Is there a mysterious BIOS setting that might hold the key? For instance, does it matter if the BIOS is seeing the SATA drives as AHCI or IDE? I've tried these repair options with either and it seems to matter very little.

UPDATE:
I removed one of the 2 sticks of RAM and was able to boot from the Windows 7 Upgrade DVD. I selected a language, then on the next screen, I selected "Repair ..." This brought me to the System Restore menu, so I opted for Startup Repair. Startup Repair hummed along for a few minutes, progress bar progressing, until finally it said "Startup Repair cannot repair this computer automatically ..."

At this point, I selected Command Prompt and followed the instructions I discovered here. Specifically, I did the following:

# > bootrec /RebuildBcd

The report back was as follows:

# > Successfully scanned Windows installations.
# > Total identified Windows installations: 0
# > The operation completed successfully

And so, I did this:

bcdedit /export C:\BCD_Backup
c:
cd boot
attrib bcd -s -h -r
ren c:\boot\bcd bcd.old
bootrec /rebuildbcd

This completed successfully. I typed "exit" and allowed the system to report. Once it did, I was back in Windows 7 (albeit with default drivers). But once I logged back in, Windows 7 started assigning drivers to everything in turn, rebooting three times in the process. Once that was done, I had a functioning machine again.

Of course, when I tried to boot with the other 2GB stick of RAM in place, Windows rebooted at the first logo screen. However, with just the one 2GB stick, Windows boots just fine. So all in all, I don't mind having to exchange half of my RAM for some that function.

But now I am starting to wonder if something is threatening to short my system. Something lurking under my motherboard. So I might be asking another question soon ...
January 18, 2010 2:11:15 AM

put an XP disk in there and boot off of it to format that drive. Then just reinstall win7
m
0
l
!