Sign in with
Sign up | Sign in
Your question
Solved

Fresh Windows Install, NTLDR missing?

Last response: in Windows XP
Share
August 17, 2012 6:18:38 AM

Hello everyone. Got a bit of a problem. I got a bunch of retired machines from a customer (domain users) and am in the process of wiping them and doing fresh installs of Win. XP SP2. They are a mix of PATA and SATA interfaces, and so far I've had nothing but trouble with the SATA machines.

I know how to install Windows (done it a lot) and have never had this problem. I mounted the machine's HDD (it's a SATA) with my USB adapter and formatted it NTFS quick format like I always do no problem, installed it back in the machine, and tried to boot off the Win. XP install disk, it has a hard time finding the HDD. I went into BIOS and changed the boot order so it would boot from the CD-ROM drive and it loaded the Windows installer, then quit on me.

I tried it a few more times to no avail, kept getting the "no operating system" and "no bootable media." BIOS sees the SATA drive, but for some reason the install keeps failing. It will get up to the point where all the drivers are loaded and proceeds to the Windows XP screen, then reboots and I get the blue screen saying it shut down Windows due to hardware changes. I thought it was a driver issue so I used my XP boot disk with SATA drivers in it, same deal.

I tried blowing an image of another XP machine onto the drive, and it will get to the Windows XP screen then do the same thing. I tried swapping out the SATA drive for a PATA drive with Windows already on it, but that didn't work, did the same thing, loads Windows, then reboots. I can see a blue screen flash real quick during the rebooting. I tried reinstalling Windows on the IDE drive, and that didn't work either.

Now after all that, I am getting the NTLDR missing warning despite having a good image of an XP machine and a functioning XP boot disk.

For yuks, the machine is an Enpower Nitro-08 with an AMD Athlon 64 X2 4000+, generic main board, PC-2 5300 667 MHz RAM 2 GB (I think 184 pin). It originally had a WD Caviar 320 GB SATA 150 MB/s HDD, but I was also using a Hitatchi Deskstar 89.2 GB IDE and a WD Caviar 40 GB IDE. I formatted all of them and started over to no avail.

Someone told me that XP sometimes has trouble going onto machines with SATA drives, a driver problem or something and you need to change a BIOS setting to get it to work and sometimes install the SATA drivers from the MB manufacturer (the old "F6" deal).

This is driving me nuts, and I have 2 more machines to do with this same interface. They both have Win 7, one Pro one Premium, but will end up as XP pro's.

Thoughts?

Thanks!

Best solution

August 17, 2012 2:33:37 PM

Go to the BIOS and change disk mode from AHCI to ATA if it's not on that already.
Share
August 18, 2012 5:08:32 AM

I tried that today and nothing changed. Enabled and disabled SATA. I stopped getting the NTLDR missing message though, I think because I'm booting (or at least attempting) from a disk with a full OS on it (the disk I imaged). I tried both the SATA and the IDE disks...same deal. It will boot ti the splash screen, then flash a blue screen, then reboot, then give me a warning saying the hardware had changed and whether to restart Windows in safe mode (like if you hit F8), but my keyboard doesn't work. Same with the boot screen (F12). I get the boot menu, but my keyboard doesn't work.

This is strangeness. I am going to redo everything tonight, format the drives and start over. I made a new Win. boot disk as well in case the old one was "damaged" somehow. I'll reset the BIOS too and use the default setting with the SATA disk. This machine HAD Windows XP pro on it when I wiped it, so it must have had the SATA drivers in there. I don't understand why it's behaving this way.

Thanks! Let me know if you think of anything.
m
0
l
Related resources
August 18, 2012 7:28:40 AM

An update...

I formatted both IDE and SATA drives, reset the BIOS (took out the CMOS bat for 10 min), hooked everything up, popped in the Win boot disk, powered it up and....nothing. The power comes on, the CPU and PS fans work, HDD, floppy, and optical drive work, but no video.

This is incredibly irritating.

Any thoughts, or is this landfill fodder? It worked fine when I first turned it on when I got it, booted up fine, it was only after I attempted to install Windows I started getting issues.

Thanks.
m
0
l
August 19, 2012 5:04:17 AM

Another progress report...finally got the Windows CD to load into setup, but only after I took the MB out, unhooked everything, tested the PS, swapped the RAM modules (turns out one was no good), and repartitioned the HDD. I tried the SATA drive for the install, and it went just fine up until it came to the part where the setup needed to reboot before proceeding. Well, on the reboot, it did the usual POST and attempted to boot from the Windows CD, but the POST screen did some weird things before hanging on the "press any key to boot from CD." Some of the letters in the POST screen got highlighted red, and some weird green symbols popped up (they looked like hieroglyphics sort of). Weird. So I shut down, changed the boot order in BIOS (it wouldn't let me do it from F12 until I changed from a USB keyboard to a PS/2) to the HDD, and it just hangs on the "verifying DMI pool data" prompt. So, I swapped out the SATA drive for a PATA drive I had laying around and tried to do it that way, but now it won't boot from the CD drive as I get the message "boot disk failure. Insert system disk and press enter." Could it be a jumper problem? The PATA drive doesn't have any jumpers on it, but the CD drive does. How do I go about changing that?

Thanks.
m
0
l
August 20, 2012 3:20:11 PM

If you have both ATA drives on the same cable, need to set them to be either auto detect or manually set to master and slave drive. The Hard-drive should be set to Master. Need to get a jumper for it if you don't have one. Usually if you have no jumper it is set to Cable Select but you need both drives to be set to that.
m
0
l
August 20, 2012 7:26:05 PM

hang-the-9 said:
If you have both ATA drives on the same cable, need to set them to be either auto detect or manually set to master and slave drive. The Hard-drive should be set to Master. Need to get a jumper for it if you don't have one. Usually if you have no jumper it is set to Cable Select but you need both drives to be set to that.


Hang, Thanks for the reply!

I have tried changing the jumper settings because I had two IDE drives (the IDE HDD and optical drive) on the same ribbon. I set the HDD to primary master and the optical drive to slave, so that should be good, as it worked on my other machine I downgraded to XP. I have done 4 other machines like this, 3 with SATA drives with no problems.

I did get the Windows setup to load (running on the IDE and SATA HDD) and it went through the win executive driver load, then went it got to the point where you install Windows ("hit enter") it says no drive detected using the SATA, but it then says it can't find the drive...fine. I tried a slipstream boot disk with the NVIDIA SATA storage drivers in it, and they load as executive files, but it can't find the drive. BIOS does, POST does, not Windows.

So, I tried using the IDE drive. It loads the drivers fine, gets to the second stage of installation, but when it gets to the point where you reboot to continue the install, it never gets past the BIOS. Instead I get a screen (I wished I could insert a picture here) after POST with the CD booting message ("press any key to boot from CD") but it hangs there and I get weird colored squares pop up all over the screen and weird symbols? Is this a sign of a bad motherboard or RAM? I'm going to test the RAM today and give it one last shot. Is there anything else I can test? This machine was working fine with Windows XP pro when I wiped it. It was after I did that it's been acting up.

I have put a lot of time into this and it's getting frustrating :fou: 

m
0
l
August 20, 2012 7:59:44 PM

I also forgot to mention that the Mobo isn't generic: It's a Gigabyte GA-M61SME-S2 with the AMD socket AM2+

I found the F6 floppy drivers and slipstreamed them onto the Win. XP boot CD so I will try that (again) later and report in. I will be doing it from the IDE drive first, then the SATA if everything works. How I did it for the others (except one) is to blow Windows on the IDE drive, load the SATA/storage drivers (and other drivers, chipset, VGA, audio, network, etc.), plug in the SATA drive as a second drive, and see if it works. If it does, I'll image the IDE drive and blow the image onto the SATA drive and it worked fine.

Thanks.
m
0
l
August 20, 2012 9:43:38 PM

Well as an update. Using the new ISO disk, no luck. It won't boot from the CD and gave me the same weirdness as before. So, I checked the RAM with memtest86+ for a full test (I didn't run it for 6 hours) on both DIMM's (PC2-533 667 1 GB x2) with no problems. I tried swapping them between slots, and then something weird happened.

One stick threw an error in the first slot (closest to CPU), no POST just a series of long beeps. I moved the same stick to the outboard slot and it was fine. I tried the other stick in both slots and no errors at all. I took some PC2-4200 sticks from another machine and it was fine in both slots. Then, I tried it again, and the inboard slot threw an error with both sticks.

Weird.

At this point I am leaning towards a failing MB...but, I ran the Win. setup again, and it boots from the CD (good), loads the drivers I slipstreamed (good), but fails to detect the disk 8*(

When I run it from the IDE (with the IDE HDD, not SATA on IDE), it does the weird colored numbers/symbols thing when it says "verifying DMI pool data" (when it should boot from the CD).

Bad motherboard?

Thanks again!
m
0
l
August 21, 2012 2:16:19 PM

Sounds like that ram slot at least is bad. Can you run the system using the other slots?
m
0
l
August 27, 2012 8:03:55 PM

Thanks for the reply!

I tried swapping RAM between slots, and it will work on the second slot with any module I put in it, but it won't on the other slot.

I kept experiencing the weird behavior on the POST screen, so I deduced that the motherboard is failing. I tried posting a picture of it on here, but couldn't get it to work. It had a few bulging capacitors, and I know that's not always the reason a board is glitching, but it seemed like the case here. So now it's going to be parted out. It was free, so I'm not shedding any tears over it. It's being replaced by a P4 ASUS P4P800-VM. Ancient compared to the dead one, but hey, it works!

m
0
l
August 30, 2012 8:00:41 PM

Best answer selected by sirstinky.
m
0
l
!