ASUS P5KPL/1600 PCI Problem

Hey guys I am new to these forums and am not entirely sure if this is the right topic to posting this in but it's worth a shot.

Basically, a few days ago I was busy gaming and my PC froze (didn't blue screen just froze frame for minutes) so I did a cold reboot. When it booted up again all of a sudden it said a new PCI device had been found (at this point its worth nothing I use a Realtek RTL8139/810x Family Fast Ethernet NIC as a LAN adapter).

The only thing I had changed before that was I updated my AVG but I doubt that had any effect on the PC itself.

I have tried updating the BIOS, reinstalling the LAN adapter drivers (which aren't recognized when I search the driver CD for the driver), a different LAN adapter (so I am certain it's not the actual adapter and more likely the PCI on the mobo).

The screenshot below shows what confuses me - as far as I know the LAN adapter and the "PCI Device" are the same thing. I don't have anything else connected in on a PCI slot and no drivers seem to work for the unknown device, so what else could it be?

I don't understand what could be conflicting with it as the unknown device is disabled and there doesn't seem to be a problem with the IRQ's.

If you think something I mentioned above could solve it please just tell me and I will try it again.

Thanks a lot in advance,

Hardware:
ASUS P5KPL/1600
Realtek RTL8139/810x Family Fast Ethernet NIC
*Just let me know if you need full hardware specifications but I think this is all that is necessary.

http://img189.imageshack.us/img189/3166/lanadapterproblem.png

Uploaded with ImageShack.us
6 answers Last reply
More about asus p5kpl 1600 problem
  1. Tried and didn't work.

    Thanks though.
  2. One other thing to try is to go to Device manager, right click on the Realtek LAN adapter and uninstall it. Reboot the system and let windows find the LAN controller and reinstall the driver.
  3. You need to go to the Details Tab for the PCI Device and get the PCI hardware ID for the device.
  4. I'm not sure if this is even helpful but I recently uninstalled the Asus Wi-Fi AP Solo driver from the program list as it was annoying me, couldn't stop it running at start up.

    The second it was uninstalled, I lost the net. Inserted the disc and it didn't have any drivers listed when autoplayed. I restarted and windows could not find the driver on the disc either.

    I explored the contents of the disc manually and found under the folder drivers/wifi/ was then given the choice between 32 & 64 bit, ran the set up exe and all was fine and dandy.

    If you like I will give you the exact directory to find the install file when I get back from work.


    p.s. Are you running your FSB at 1600mhz? What is your average mobo temp? I'm considering getting a Asus Rampage Extreme 775 DDR3 - PCIe SATA RAID Controllers are soo damned expensive. See my post "Swap P5K-Premium for Asus Rampage Extreme"

    Hope this helps.
  5. I know that my problem refers to a self-inflicted Wi-Fi adapter problem, but as it's a PCI device that came with the mobo I thought this may be of some help.

    Usually reinstalling it is a good cure-all. My Devices list looked simular to yours after I had uninstalled the drivers for the WiFi Adapter. I'm now working on a Scheduled Task to exit the program shortly after I've obtained a network connection.

    I know the P5K-Premium has two different SATA controllers and two different eternet controllers and and PCI Wifi Controller - so finding the right driver wasn't fun.
Ask a new question

Read More

Asus PCI Motherboards