FX-8150 CPU speed problem

Hey ppl from tomshardware, im currently having a problem with my fx-8150, it downclock itself down to 1.3-1.4 ghz while idle and that is fine but whenever I am playing a more demanding game ( Ghost Recon, Battlefield 3, WoW, Dead Space 2 )
it will randomly downclock itself to 1.3-1.4 ghz while in-game and cause little lag spikes.
It also goes down to 1.3-1.4 ghz when im ALT Tabbing out of a game and then it will take several seconds ( 7-8 ) before the game re-opens back up after clicking on it because the CPU speed stays at 1.3-1.4 ghz until the game is up again. I am looking at the core speed on CPU-Z
Also there is an older game( can be played on single core ) I play that makes my CPU stay in turbo boost( it will go from 3.9 to 4.6 ghz and the stock core is 3.6) all the time and reach high temps(55-60 celcius)

What can I do to fix this?

Specs :
AMD FX-8150
ASUS Sabertooth 990FX
ASUS GeForce GTX 550 TI
Corsair Vengeance 16GB @ 1600MHZ
Corsair 650TX PSU
1TB 7200RPM HDD

About the cooling, I am using a Zalman Z11 PLUS case and it keeps the temperatures within what it should be. It is not a cooling problem.

I have tried many things such as disabling power saving options in the bios and it just won't run 3.6ghz when needed and if anything, it just won't run 3.6ghz at all. Its either 1.3-1.4 or max turbo boost while not necessary.

Any suggestions?
8 answers Last reply
More about 8150 speed problem
  1. I would like to add that the CPU speed is going from 1.4 ghz to 3.9-4.2 ghz every 2-3 secs while idling.
    The Cool&Quiet thing in the bios is DISABLED if anyone was thinking about that.
  2. sounds fine to me if ur looking at core temp which will show ur cores all at 3.9 all the time its because core temp dont really work that well with fx chips. as for ya first comment i would clear ya cmos and start again and to me it sounds like u made the boo boo by changing it from 1.4ghz to 1.3ghz just leave it how it was unless ur overclocking.
  3. I didn't change anything, it underclocks itself to that core speed, I am not overclocking or anything, I just want to it run at least 3.6 ghz during games and not use turbo boost when not necessary.
  4. bit weird maybe try clearing cmos anyway or go in bios and try resetting back to default see if that makes any changes. also turn off turbo core in bios to.. dont really no y u would wanna do that as it gives u a overclock but ur choice...
  5. Basically, I just want it to stop downclocking itself and just stay at its normal clock speed ( 3.6ghz ) unless turbo boost is necessary. Anything I can do for that? and what is cmos? im a newbie :)
  6. I just read on clearing CMOS and no that would be pointless because nothing is changed in my bios besides ram speed which is at 1600 because stock gives you 1333
  7. ok yeah sorry just woke up so wasnt really reading what u put lol... the chips all down clock to save power theres nothing u can do to change this its perfectly normal dude it wont effect your system in anyway if anything its a good thing as less volts means less heat which means longer lasting chip. (mines the same only changes from 1.4gz to 4ghz)
  8. yea I know that already but it sucks when you tab out of a game and it takes about 5-6 sec to re-open. or when you are loading but ur friend with dual core loads faster than your because your sleeping at 1.4 ghz. and also idk why but sometimes it just stays in turbo boost while playing old games that wouldnt require more than stock core speed.
Ask a new question

Read More

AMD Games CPUs Overclocking