Sign in with
Sign up | Sign in
Your question

Storage Drive not seen in bios !

Last response: in Storage
Share
January 13, 2012 6:24:27 AM

I have just swapped my Asus P8P67 Pro B3 Revision due due to having a bent pin on the cpu socket for the P8Z68-V Pro/Gen3 i plugged everything in apart from my 1TB western digital caviar black storage drive due to not wanting to accidently wipe it on windows re-install up on finishing the reinstall and reconnecting the storage drive the bios does not seen anything at all ! i've tried different sata 6.0 cables and sockets and nothing help !! id appreciate any help any1 can give as im lost !!

More about : storage drive bios

January 13, 2012 6:46:37 AM

cool Powercable for hdd is lose so reconnect it ,same problem try other prowercable
January 13, 2012 6:51:14 AM

tried power cable straight away m8 no joy with that !
Related resources
January 13, 2012 6:52:05 AM

Do you mean there is no display or BIOS says HDD missing/boot error?
January 13, 2012 6:56:37 AM

i mean it does not appear in bios at all ! tho i have got an unknown device on device manager not sure if that would happen with if didnt show on bios tho
January 13, 2012 7:11:43 AM

So you have two HDD. If bios cant find the hdd and connection is okay then there may be hdd error and windows will not detect as unknown device. Is that unknown device is under Disk drive in device manager?
January 13, 2012 7:26:03 AM

Assuming it's Sata, check which port you connected it to. Some are used by the raid controller and it wont show if it's not set correctly. If you're not using it in raid, it's easiest and best to connect it to a non-raid port. Also check if your sata is set to the right setting: raid/ide/ahci.
January 13, 2012 7:27:57 AM

yes 2 hard drives ! C drive is a SSD and Caviar black is storage ive just checked device manager for this unknown device and it does'nt show any longer but bios still does not see HD, would having installed the system without the storage drive connected have caused this problem ?
January 13, 2012 7:35:23 AM

Bios is not affected bij OS installation as fas as seeing hardware is concerned. It is designed to make hardware accessible before an OS is installed so hardware can be installed and controlled propperly by an OS.
January 13, 2012 7:45:16 AM

i've just checked and the sata setting is AHCI for the drives but the drive its self does not show up !
January 13, 2012 8:12:33 AM

The 2 sata connectors nearest to the memory slots on your board are for the marvel raid controller the other are for the intel controller. make sure you have your drive connected to the intel connectors.
January 13, 2012 3:23:09 PM

i've found out whats wrong with the hard drive ! it seems that the power connector is broken as ive tried another sata hard drive on same power connector cable and it powers up ! the 9 months old caviar black wont have any of it tho :(  cant believe its broken already !!
!