Sign in with
Sign up | Sign in
Your question

SimpleTech External Hard Drive Not Recognized

Last response: in Storage
Share
January 14, 2012 12:58:04 AM

Hello,

I have the SimpleTech 250 external harddrive and it just stopped working. It turns on but is not recognized by my PC. I am not receiving any error messages and all software is current. I also tried it on a second laptop in my home and that laptop didn't recognize it either. I have switched out the USB cords and still nothing - - I have my dissertation and other important documents on this....any suggestions???
a b D Laptop
a c 317 G Storage
January 14, 2012 1:46:27 PM

Does it show up in Windows Disk Management? If so, assign it a drive letter that is not currently in use and it should show up in Windows.
m
0
l
June 20, 2012 2:49:47 AM

thodges said:
Hello,

I have the SimpleTech 250 external harddrive and it just stopped working. It turns on but is not recognized by my PC. I am not receiving any error messages and all software is current. I also tried it on a second laptop in my home and that laptop didn't recognize it either. I have switched out the USB cords and still nothing - - I have my dissertation and other important documents on this....any suggestions???

m
0
l
August 27, 2012 12:18:14 AM

thodges said:
Hello,

I have the SimpleTech 250 external harddrive and it just stopped working. It turns on but is not recognized by my PC. I am not receiving any error messages and all software is current. I also tried it on a second laptop in my home and that laptop didn't recognize it either. I have switched out the USB cords and still nothing - - I have my dissertation and other important documents on this....any suggestions???



Had this problem with simpletech 350GB external - tried it on 2PC's (Vista) and could not get pc's to recognize the drive. Check to see if you are using the correct AC power cord - I was able to resolve my problem that way. Here's the run down...hope it helps you too.

I checked the AC power cord I was using against simpletech's specs documentation and realised was using an AC cord from a different device. Once I found and plugged in the original AC cord that came with the drive (100/220V 50/60 Hz AC input, 1.5vdc output), plugged the drive back into the pc, it recognized the simpletech drive again - (on both pc's).
m
0
l
!