Sign in with
Sign up | Sign in
Your question
Solved

ACHI does not show in device manager despite bios settings and drivers, AMD syst

Last response: in Storage
Share
January 15, 2012 6:18:22 AM

Hi, I have a Kingston SSD Now v100 64 with a Gigabyte Gigabyte 78LMT-S2P board with a 760g chipset.

So I followed guides and FAQ's on how to set this up. Set to ACHI in Bios before installing Windows 7 64bit (and the other Sata setting from IDE).

So I install Windows on it, move all the User stuff and what not then move onto the Tom's guide for tweaking. First thing is to check ACHI, well my device manager does not show it enabled. All I see is AMD Sata and IDE.

I did the registry tweak suggested in the article and ran the command to check if Trim is enabled and apparently it is (I also read this is not accurate necessarily? Is that true or if Windows says it is enabled that means it is??)

I then reinstalled Windows (arg) and ran the driver for ACHI on the Gigabyte site during the Windows install.
Same deal, no ACHI showing.

I tried the Windows driver right from AMD, no dice.

The drive seems to load fast but is this irrelevant? Could Trim be enabled and the ACHI driver just not showing for some reason?

Thanks for any help.

Best solution

a c 265 G Storage
January 15, 2012 2:03:51 PM

I have my drives in ACHI in BIOS but it shows up as AMD SATA in device manager, would show up as IDE in DM not SATA if in IDE mode. If it is correct in BIOS it is running ACHI.
Share
January 15, 2012 5:09:32 PM

oh great so I reinstalled for nothing, hehe. Thanks!
m
0
l
January 15, 2012 5:09:56 PM

Best answer selected by Aquakitty.
m
0
l
!