Sign-in / Sign-up
Your question

Slow gigabit

Tags:
  • NICs
  • Motherboards
  • Components
Last response: in Components
March 27, 2010 12:13:15 PM

I have two gigabit enabled machines. The each have different motherboards, but both motherboards use the Realtek RTL8111D NIC. The machines are connected in this way:

machine 1
~15 feet of CAT6
D-Link DGL-4300 gigabit router
3 feet of CAT6
in-wall coupler rated for CAT5e
~50 feet of CAT5e
Rosewill gigabit switch
~15 feet of CAT6
machine 2

File transfers between the machines are slow. :( 

I downloaded the PCATTP tool:
http://www.pcausa.com/Utilities/pcattcp.htm
On one machine I run:
PCATTCP.exe -R 99999999
One the other I run:
pcattcp -t -f M 192.168.0.4
I see a speed of ~11MB/s (megabytes/second). If I run the second command on the same machine as the first (loopback), then I see 500MB/s.

There shouldn't be a problem mixing CAT5e and CAT6, and both can do gigabit.

To try to simplify the test, I replaced the Rosewill switch with a CAT5e inline coupler. I still see only ~11MB/s.

Do you think a cable or coupler is damaged? Should I get a tester tool? It seems if there was a bad connection or damaged cable that the connection would be reliable. I use the internet through machine 2 every day and it is fine.

Does anyone have any ideas on how to fix my slow transfer speeds? Both machines are running Windows 7 Ultimate, and both have Intel X25-M SSDs. I have set both NICs to 1gbps full duplex. Are there any other settings I should look at? Anything at all that could help?

More about : slow gigabit

a b V Motherboard
March 27, 2010 6:55:04 PM

Does the router have the latest firmware?
m
0
l
a c 407 V Motherboard
March 27, 2010 11:21:43 PM

swap machine to test the current cabling.

Have you looked thru the config and made sure its set to use gigabit instead of 10/100? Different mobo's often have different defaults.
m
0
l
Related resources
March 28, 2010 9:56:12 AM

Yes, the router has the latest firmware, 1.8.

Swapping the machines is a good idea. PITA, but a good idea. :D 

I don't remember any gigabit settings in the BIOS, but I'll check again.

If I set the speed back to auto negotiate, machine 1 shows up with a link speed of 1000, but machine 2 shows up with 100. Both machines have the same NIC and are using the same driver. I have ordered a cable tester from the egg, something might be messed up since 10/100 uses 2 pairs and 1000 uses 4. I may swap the machines in the meantime, since that will give pretty good proof it is the cabling. It is just the servers are heavy, and there are 3 floors to carry them.. :p 
m
0
l
a b V Motherboard
March 28, 2010 9:28:51 PM

What are you using to test the transfer? It will not transfer faster than the hard drives support. Multiple small files also take a lot longer than a few large files. Let's just make sure to eliminate that as a possible issue.
m
0
l
March 28, 2010 9:54:23 PM

I described my testing procedure in the first post. Also, file transfers are slow even when both machines have an SSD.
m
0
l