Lots of artifacts on two graphic cards

Hello, new to the forum scene while an avid reader of the various articles and reviews on tom's hardware
hope you don't bite.

I have encountered major artifact problems in games / 3d apps, now this all started when i installed a new asus ROG crosshair III formula motherboard, new ddr3 ram and now my ati radeon 4890 & nvidia geforce 9800GT both encounter these huge problems, it actually seems to be getting worse wereas beforehand it was minor flicker on the screen, a ingame screenshot taken in crysis shows how bad it is now.

http://img686.imageshack.us/img686/6804/crysisartifacts.png

I am totally lost as to what could be causing this, the obvious choice is the new motherboard/ram and i am quite worried about the problem especially after spending alot of money on a few peices of hardware.

pc specs:
amd phenom II x3 720 BE
corsair 750w PSU
ati radeon 4890/nvidia 9800gt
asus crosshair III formula motherboard
ocz ddr3 1600 2x2gb

Any help is hugely appreciated.
thank you in advance
15 answers Last reply
More about lots artifacts graphic cards
  1. Any help possible? really worried about it
  2. how about the card's temps?
    Did u try to re-install the game?
  3. Doesn't look like the artifacts from overheating. I'd suspect drivers' issue first.

    Whwn you changed motherboards, did you do a fresh OS install?
  4. Hey City

    No biting here.

    Artifacting like that may be driver related but I always suspect voltage or heat first. Lets rule those out.
    What does GPUz say about temp and voltages on the 4890 when running something in 3d?
    Run CPUID HWMonitor for case temps.
    Are your fans running - take the side off and see what happens.

    There are LEDS on that 4890 - are any lit? They should not be.

    Did you connect the power to the motherboard properly? Look for missing connectors, or not fully pushed in.

    Try a different power line from the power supply - it could possibly be the PSU. Do you have another to try?

    That its happening on both cards (right?) indicates its something in your system. Did you overclock the PCIe bus?

    Remove everything you can that may be plugged into the PCIe bus
  5. Hey thanks for the replies

    the gpu temps when i play very demanding games such as crysis rise to about 60-65 degrees max.

    All the fans are running and i see no leds on the card lit

    i will double check all the motherboard connections
    i do have a 550w power supply i could use but that might be alittle too little power

    i dont think i overclocked the pcie bus, but something i noticed on gpuz in the bus interface box : pci-e 2.0 x16 @ x8 v.1 is what it's running at currently
    (cpu hw monitor screenshot and gpuz)
    http://img42.imageshack.us/img42/1995/cpuhw.jpg
    http://img42.imageshack.us/img42/7899/gpunj.jpg

    I did not do a fresh OS install when i replaced the motherboard however i did a full clear install today

    thanks again in advance
  6. Temps looks good. Let us know if the fresh OS install/fresh drivers solved the problem.
  7. Can't even play any games or 3d mark within 10seconds of starting the apps.
    The display driver has stopped working and has recovered, all the 3d apps crash and close, happens every time. tried both my graphic cards, impossible to play any games and can't find any fix
  8. with another fresh install, the artifacts are getting worse,
    its not possible to play games atm and also i am getting The display driver has stopped responding and has recovered using both cards aswell, using the cards in another pc they are fine... need much help as possible brand new pc:s
  9. Are you using both the ATI and NVidia cards together?
  10. citytiger said:
    with another fresh install, the artifacts are getting worse,
    its not possible to play games atm and also i am getting The display driver has stopped responding and has recovered using both cards aswell, using the cards in another pc they are fine... need much help as possible brand new pc:s


    Have you tried uninstalling all the GPU Drivers, deleting all related folders to them, rebooting in safe mode, then using DriverSweeper i believe its called to make sure there isnt any drivers left, then installing drivers?
  11. No i am not using both cards together, took it to a pc repair shop and all hardware is fine, no clue what to do, games and 3d apps are just unplayable...
    tried everything, your display driver has stopped responding and has recovered blabla
  12. Well then you have to isolate what's corrupting the device driver. I usually get the same message "your display driver has stopped responding..." if I'm overclocking the SPU and RAM beyond stabilitiy.
  13. When you say fresh install, do you mean a complete reinstall from a blank HDD?

    Or do you mean another driver installation? Have you installed drive sweeper and eliminated the hidden drivers in your registry?
  14. Btw, those pictures aren't artifacting...that's just some software issue.

    Is your Crysis game updated with the latest patches?
    Latest Nvidia or ATI driver after cleaning out your registry with drive sweeper?
Ask a new question

Read More

Graphics Cards Graphics