ASUS EZ Flash 2 - won't load

Hi,

I'm attempting to update my BIOS. I've downloaded the latest version, stuck it on a memory stick and am trying to access "ASUS EZ Flash 2" by pressing Alt+F2 when booting up. This works, in so much that it starts up EZ Flash 2 but then it keeps endlessly cycling through "checking for floppy, floppy not found" and "checking CD-ROM Drive" or similar, without ever getting past them and finding the USB stick.

Does anyone know a way to fix this? I've tried it in every USB port on my pc.

Thanks :-)
7 answers Last reply
More about asus flash load
  1. MOBO is an ASUS® P5LD2 SE/C: DUAL DDR2, S-ATA, x16 VGA, 3 PCI/3 PCI-EX

    Can't edit my own post for some reason.
  2. Get into BIOS first, then Tools. There you will find EZ Flash tool.

    The USB stick should be formatted FAT32 and the BIOS file should be in the root of the USB stick, not in a folder. The USB stick should be inserted before you get into BIOS.
  3. When I go into BIOS I don't have any options for it though - the USB drive shows up but only as a connected drive.

    It doesn't work when Alt+F2'ing into EZ Flash - just loops through drives which don't contain the BIOS data.
  4. USB drive takes the drive letter A:\ in EZ Flash 2. You can choose it with the Tab key.
  5. suat said:
    USB drive takes the drive letter A:\ in EZ Flash 2. You can choose it with the Tab key.


    Hi,

    Thanks for the reply - I'm not able to run EZ Flash though - whether by a) running it with Alt + F2 (it doesn't load/detect the USB drive) or b) selecting it through BIOS/Tools (no option to).

    BIOS does pick up the USB drive though, as it appears in the connected peripheral list.

    Very confusing :-(
  6. I have downloaded your motherboard manual. I am sorry to advise that your motherboard does not support BIOS updating through USB flash disk. But it does support floppy diskette.

    Look at your motherboard CD and find the name of the ROM file. Download a newer BIOS and rename it to the one on the motherboard CD (The manual suggests the name P5LD2-SE.ROM). The name of BIOS file should not exceed 8 characters and extension, 3 characters. Then try updating your BIOS this way.

    If you do not have Floppy Diskette drive, then you should use Asus update utility to update BIOS in Windows environment. I do not know if you have Windows.
  7. In the end I tried the ASUS update tool - there was some bad mojo about it on the internetz but it seems to have worked fine for me. Probably just a few kneejerkers and dingbats who messed up using it.

    Thanks for your help :-)
Ask a new question

Read More

Asus Floppy Disk Flash Motherboards