Closed Solved

Ide-sata drive not working

i have plugged in a ide dvd drive to a ide-sata adapter and it wont detect the drive (but the drive still gets power), i have tried all the sata ports, but to no avail.

and yes i do know for a fact that the drive works

also its not showing up in the device manager

any suggestions?

870s-g46 mobo

hitatchi GCC-4482B

phenom ii X4 960T
8GB corasir ddr3 ram
haf-912 case
raedon hd 6850
rosewill green 650W
8 answers Last reply Best Answer
More about sata drive working
  1. Best answer
    Is the drive set to "Master" many of those adapters don't work unless it is set that way.

    Check the jumper block at the back of the drive.
  2. nukemaster said:
    Is the drive set to "Master" many of those adapters don't work unless it is set that way.

    i dont think is is, would that be in the bios? cuz i dont even think i can find it there but ill check
  3. Nope, edited my post, it is a set of pins on the back of the drive.

    This is not your drive, but should be similar. the jumper needs to be under the MA or MASTER section. In some cases, just removing it will work as well
  4. nukemaster said:
    Nope, edited my post, it is a set of pins on the back of the drive.

    This is not your drive, but should be similar. the jumper needs to be under the MA section. In some cases, just removing it will work as well
    http://img641.imageshack.us/img641/4603/dvdmaster.png


    as soon as you said jumper i knew what you were talking about!
    (ive had some bios problems where i had to play with the jumper for like an hour)
    i think i got it, its the one labeled MA im assuming
    testing now, brb
  5. Best answer selected by swords24.
  6. its working, you are awesome!!!
  7. That is also a common problem people have with IDE-> USB adapters.

    Enjoy.
  8. This topic has been closed by Mousemonkey
Ask a new question

Read More

DVD Drives SATA Storage