Sign in with
Sign up | Sign in
Your question

SSD issues in Windows

Last response: in Storage
Share
January 18, 2012 12:43:52 AM

Hello,
I am having trouble installing my new SSD. I have spent several hours in these forums and online about the installation of SSDs, but have not come across anything that seems to help my situation. I am trying to use the SSD as just an OS/few apps drive, and adding HDD for storage later (I am not worried about the HDD at this time though).

First, here are my specs:

Mobo: Biostar TA870u3+ (Tseries) (AMI BIOS)
Chipset: AMD 870, AMD SB850
SSD: Intel 320 Series, 80GB 2.5in, SATA II
CPU: AMD Phenom II X4 955

notes:
1. My Mobo manual, and BIOS both tell me AHCI is supported
2. I have never updated my BIOS since there has never been a need to
3. I have 6 SATA III ports, split up 2 and 4, I do not know which port I need to use for AHCI if necessary to choose


From the many different installation procedures I have seen I chose to follow the most prevelant steps I came across. I am using a clean install of Windows 7 Ultimate for this process.

1. I disconnected my previous HDD, and connected the new SSD (SSD and DVD-RW Drive, only drives connected)
2. I enabled AHCI in BIOS
3. I installed Windows 7 Ultimate

Originally I had planned on updating the firmware with an image disc right before installing Windows, but for some reason the program kept telling me that it could not find an SSD connected to my system, so instead I decided to install Windows first.

When I first got into Windows I went directly to Device Manager to see if the drive was installed correctly, and to my surprise it seemed fine because at first one of the controllers listed had AHCI in its name so I thought it was okay.

Right afterwards I installed the drivers that came with my motherboard on the supplied Drivers and Utilities CD, which are as follows and installed in the order as written:

1. ATI Chipset Driver
2. ASMedia USB 3.0 Host Controller Driver
3. Realtek Network Chip Driver
4. Realtek HD Audio Driver

Upon finishing all the driver installations and the necessary restarts, I re-entered Device Manager to notice that my Controllers no longer listed any with AHCI in the name this time. I do not know if this had anything to do with the driver installs or not and that may not even matter.

I then decided to look for key signs that AHCI and TRIM were enabled so I went into CMD saw that TRIM is enabled. I went to my registry, went to the msahci folder and the value with "start" is 0. I restarted my PC to look at my BIOS and AHCI is still enabled. I ran the AS SSD Benchmark and the result was clearly not what it should be.

I have no idea why it seems that BIOS is saying AHCI is enabled and Windows only seemed to acknowledge it for the time before I installed system drivers.

I am assuming that I have done something wrong because I am very doubtful my SSD is at its fullest capabilities. Windows works without a hitch but I am not sure about the drive.

If there are any suggestions on what I should do, that would be most appreciated. I do not care if I have to reinstall Windows. I have spent many hours on this already so if anyone has any ideas (proven or not) I am all ears.

Thanks for bearing with me through this long post.

More about : ssd issues windows

a c 351 G Storage
January 18, 2012 1:10:10 AM

What did AS SSD report the driver as, Upper left when opening AS SSD.

- Most likely you will not get "Advertized" speeds.
- Putting a Sata II SSD on SATA III will not improve performance.
Max performance is based on "intel chipset, runing the Intel iaSTor driver (vs msahci).
- Don't sweat lower Sequencial speeds as these are the least importand matrix anyway.
- REAL test for a OS + Program drive is how it performace based on PCMark vantage, which is closer to real life.
- How does the SSD perform in YOUR system. IE How is the load windows + start programs time and how does it compare to simular system - Toughy, as people have different configurations. My desktop, 128 Gig Samsung 830 on intel cipset - 12 Sec. My Laptop w/128 gig M4 - 17 Sec. My Older I5-750 w/Sata II Pheonix Pro 35 Sec, But has more start uip programs enabled than I5-2500k and laptop.
a c 98 G Storage
January 18, 2012 1:11:49 AM

Your ACHI driver was probably changed to "Storage Controller" in the Device Manager by the chipset driver install. Mine is.

This is correct.

AS SSD gives different results than ATTO benchmarks. AS SSD uses incompressible data, and ATTO uses compressible data. Most SSD are benmarked with ATTO. Don't sweat it!

I'm sure you BIOS is correct, and Windows is correct. There is a registry tweak somewhere to check if ACHI is enabled, but it should be.
Related resources
January 18, 2012 1:21:52 AM

"AMD SATA controller" is AMD's AHCI driver. Your motherboard probably installed this driver when you installed things off the motherboard disc, which is fine as long as it's there in device manager.

You may have to be more specific as to why you don't feel you're getting the best performance.


January 18, 2012 2:00:12 AM

I can definitely see the difference from my previous setup. Everything is the same as my previous setup with the exception of having the SSD instead of HDD

I know that it is working but I felt like maybe I had an issue because:

a) the firmware upgrade told me there was no SSD present
b) no ahci under controllers in Device Manager (but you say i may not need that since Chipset driver changed it to "AMD SATA Controller"
c) the AS SSD benchmark

To answer RetiredChief:

in the top left, from the AS SSD it said pciide


Thanks for all the help!
January 18, 2012 2:01:51 AM

1 more reason I was concerned was because i didnt know if it mattered what sata port i used
a c 351 G Storage
January 18, 2012 11:04:49 AM

"pciide" should equal BAD.
Will have reduced performance.

From OCZ, But generic in nature so should apply to other systems.
a c 98 G Storage
January 18, 2012 8:52:56 PM

It's all probably because you are on a non-Intel motherboard chipset. I couldn't run toolbox or other things on my HP PAvilion, with a AMD chipset, but the SSD worked.

An try running ATTO benchmarks. BUT DON'T RUN TOO MANY BENCHMARKS! It WILL degrade your SSD!

But if you notice it's faster than before: it's better than it was, and that's all you'll get or need.
a c 351 G Storage
January 18, 2012 9:05:50 PM

Pcide is not correct, should be either msahci or iaSTor (for Intel), or xxxxx(for amd)
msahci should work on eith intel or amd
January 19, 2012 8:48:00 PM

RetiredChief said:
Pcide is not correct, should be either msahci or iaSTor (for Intel), or xxxxx(for amd)
msahci should work on eith intel or amd



Is there anything else I can try to change this then? BIOS still says AHCI enabled, as well as TRIM when in CMD and the msahci location in the registry "start" value=0.

What could I possibly be missing?

Thanks again for all the responses
January 20, 2012 1:00:37 AM

Alright, thank you for all the swift responses everyone, I have figured out my problems. Thanks for all the help.

As it turned out there were 2 tweaks I needed to make.

1) My BIOS is hard to understand in SB configurations as well as my mobo manual not giving any help, as to how to properly set up AHCI. It turned out that I had my SSD connected to the incorrect port. Once that was corrected the pciide on the AS SSD benchmark was altered to msahci.

2) I also installed the most current AMD AHCI drivers for Windows 7 directly from the AMD website


I can now see a complete difference. My benchmark scores drastically increased as well as my WEI Disk score.

Once again thanks for all the input, which without I would have failed at finding the answer.


As a side note, some company needs to expand instructions on SSD implementation, its ridiculous how much time I spent unsuccessfully installing, reinstalling, researching, etc. Either SSD, motherboard, or chipset manufactureres need to give a little more instruction. It is crazy.
!