Sign in with
Sign up | Sign in
Your question

Installing new video card

Last response: in Graphics & Displays
Share
January 16, 2010 7:43:18 PM

I am trying to install a new video card in to my aging system, hoping to give it a little more pep until we can afford to buy a new one.

I bought a Sapphire HD 3850 and when I installed it and turned on the computer, I had no video output to the screen.

I uninstalled the drivers for my old card prior to installing new one.

Am I doing something wrong???

More about : installing video card

a b U Graphics card
January 16, 2010 11:07:32 PM

Did you connect the power cable to the card?
m
0
l
January 16, 2010 11:10:57 PM

Yes, sorry I should have stated that, but yes I did have the power supply connected to the card....
m
0
l
Related resources
a b U Graphics card
January 16, 2010 11:12:31 PM

is it the AGP or PCIE version?
how many watts is your psu? a 450w min according to the specs.
did you plug in a 6pin power connecter into the 3850? (if PCIE)
did you plug in a 8pin power connector? (if AGP) and not two 4pin connectors. (dont know if that matters)
m
0
l
January 16, 2010 11:20:07 PM

paperfox said:
is it the AGP or PCIE version?
how many watts is your psu? a 450w min according to the specs.
did you plug in a 6pin power connecter into the 3850? (if PCIE)
did you plug in a 8pin power connector? (if AGP) and not two 4pin connectors. (dont know if that matters)



PS is 420W....The card is AGP, had an adapter for the 8 pin to plug 2 4pins in to it....crap, I hope I don't have to buy a PS too!
m
0
l
!