Sign in with
Sign up | Sign in
Your question

USB HDD Enclosure intermittently works

Last response: in Storage
Share
January 19, 2012 4:32:49 PM

I have been using a NDAS NetDisk ND-10 HDD enclosure for a few years now for various media related things and I have had no problems with it. It has a ST31000520AS Barracuda LP SATA 3Gb/s 1TB Hard Drive in it.

Well the other day I hooked it up to my computer, copied a movie then hook it into my BlueRay (via USB) and the BlueRay detects it but basically freezes if II try and access the HDD and the activity light on the USB enclosure is always on. Its has worked many times with the BlurRay with no problems before. So I hooked it back into my computer and now the same thing happens with my computer where a second ago it was perfectly fine. My computer (with Windows 7 Ultimate 64bit) installs the USB mass storage device with no problems, detects the HDD but if I try and do anything with it my computer will stop responding. So I hooked it up into another computer with Windows XP and the same thing happens, so I try a third one (with Windows 7) and again the same thing and I just can't get the HDD to work anymore. All during this time I am trying different USB ports and trying to unistall/install the USB drivers over again but nothing happens and the HDD activity light is always on. This HDD I can use over a network so I tried to hook it up that way and the network NDAS software detects it fine but eventually says the HDD is not responding and crashes. I also tried a linux live disc and it is no different than windows. I then removed the HDD from the enclosure and just hooked it up like a regular one and the HDD works perfectly fine and there isn't one problem. I put it back into the enclosure and again it has the constant activity light and freezing what it is plugged into.

At this point I'm thinking there is something wrong with the enclosure. I try one last thing and hook it up to my wii (because I can load backup games from it) and go figure the wii works perfectly fine with the HDD. The HDD has one NTFS partition on it so the computers, blueray, and the wii all access the the same NTFS partition but only the wii works with USB enclosure however the HDD itself works fine without the enclosure through a SATA connection.

I'm don't have much experience with USB enclosures so I don't know the sort of problems they can have but I work in an IT field and I am familiar with troubleshooting and various computer problems I just am puzzled with what is going on here and was wondering if anyone had any other ideas I can try for troubleshooting. I'm about ready to throw the enclosure out and just use the HDD in a computer and then transfer whatever media files I want to a fat USB stick for wii/blueray stuff as I need it.
a b G Storage
January 20, 2012 10:12:47 PM

Since the HDD works outside the enclosure; you may want to try another enclosure. The circuit board inside the enclosure may have failed.
m
0
l
January 28, 2012 12:39:34 PM

I am ready to think that as well but I am confused that the enclosure works perfectly fine within the wii. I have several gigs with backup games on it and use the enclosure to access the games via a third party channel in the wii and the performance and operation of this has worked flawlessly. It uses the same enclosure, same partition and file system as the other devices (there is only one which is NTFS) I have run a chkdsk on the HDD which took quite a long time and it ended up finding and correcting a bunch of errors however that didn't change its performance on the computers/Blueray/network and again the wii still works perfectly fine.
m
0
l
!