Sign in with
Sign up | Sign in
Your question

Scythe Kama Card Reader

Last response: in Systems
Share
January 24, 2010 7:32:40 PM

Hi,

I try to connect my scythe kama card reader to my Gigabyte (MA785GMT) USB internal port on the motherboard. I have checked that the connection is right. I use Windows 7.

The green light of the reader is on, however the reader does not work. I have checked with the external USB cable, then it works fine.

Any idea?

Thanks
Martijn
January 29, 2010 3:29:32 AM

Then it's either a case of a faulty internal USB port, or your mobo only works with certain devices when they're connected that way. Are you able to try connecting the reader to another mobo's internal USB?
February 10, 2010 2:00:17 AM

Hey,

I've got the same issue, I've got the same reader, and I'm using Windows 7 64bit. The green light goes on, but windows doesn't recognize it and fails to install the drivers. It's showing up as an "Unknown Device" in the device manager.

The reader worked fine with Vista 64bit, and I know for sure it's installed correctly, I even tried installing it on one of the other USB headers.

Did you ever resolve this?
Related resources
March 15, 2010 9:36:07 PM

Thank god I'm not going insane. :pt1cable: 
I have the same problem with the Gigabyte GA-P55-UD4. Now I'm having a mail dispute with Gigabyte on this since November last year and they have three advices:
- Upgrade your Bios :( 
- Buy a heavier powersupply :??: 
- We never heart about a problem like this before, so look somewhere else. :fou: 

My problem actually is that the reader works however the rest of the USB devices go offline as not recognized. (No mouse, keyboard etc)
I asked Gigabyte already if there is a power problem on the USB implementation, but they repeat the three forementioned questions. :heink: 

I hope someone has fond the problem or that we can join up to face scythe and others. Someone made a mistake

Anonymous
March 19, 2010 5:23:06 PM

Damn, I am having the exact same issue. SD cards etc are working correctly, but the USB ports just don't work. Anyone has any ideas on this issue?

Best regards, Ewout


My configuration

Be-Quiet Pure Power BQT L7 350W
Conceptronic WRL NTW CONCEPTRONIC N PCI 300Mbps
Cooler Master Elite 334
Gigabyte P55M-UD2
Intel Core™ i5-750
Kingston 4GB 1333MHz DDR3 Non-ECC CL9 DIMM (Kit of 2)
Nexus 120MM BASIC SERIES | Real Silent Case Fan, BLACK/WHITE
Samsung SATA-2 1TB 32MB 7200RPM
Samsung SH-S223C/BEBE DVD�RW/DL Black
Sapphire RADEON HD 4670 512MB GDDR3 PCI-E VGA DVI-I HDMI IN
Scythe Kama Reader 2
July 8, 2010 5:56:56 AM

I have a similar problem using a Conceptronic CMULTIFPE (multi card reader with eSATA support). It is recognized in the BIOS on bootup but does not show as a device in windows, not even when a memory card is inserted (green light turns on on the front panel of the conceptronic). In my case the USB connection is fine but only the card reader does not function...so that's just the opposite of the problem mentioned in the earlier post, but the combination of windows 7 and maybe the chipset sounds suspicious...

It is connected to a Asus p7p55d-e (p55 chipset) and i am using windows 7 64-bit. I am using the latest chipset drivers from Asus and BIOS update.

Conceptronic asked me to check if the device had a question mark in the hardware manager tab (not so) and if i was using the latest chipset drivers and windows updates (which i do).

!