Problem with 9400GT, Fedora 12 and Twinview


I tried to install a Sony LCD 32" TV in TwinView mode with a Viewsonic VX922 monitor. There are lots of problems. The TV screen doesn't extend to the far right: you can see the monitor's backgroud picture to the right. (Kinda underscanning?) Pictures that show well on the monitor have the bottom missing on the TV. The bottom of the monitor's background picture appears twice and the aspect ratio is of course not correct.

Here are the error messages I could spot:


ERROR: Cannot open display 'localhost.localdomain:0.0'.

ERROR: Unable to assign attribute CursorShadow specified on line 21 of
configuration file '/root/.nvidia-settings-rc' (no Display connection).

ERROR: Unable to assign attribute CursorShadowAlpha specified on line 22 of
configuration file '/root/.nvidia-settings-rc' (no Display connection).

Etc. (no Display connection) until line 57



less /home/user/nvidia-bug-report.log.gz


(WW) Jan 16 14:31:36 NVIDIA(0): The EDID for SONY TV (DFP-1) contradicts itself: mode
(WW) Jan 16 14:31:36 NVIDIA(0): "1920x1080" is specified in the EDID; however, the EDID's
(WW) Jan 16 14:31:36 NVIDIA(0): valid VertRefresh range (58.000-62.000 Hz) would exclude
(WW) Jan 16 14:31:36 NVIDIA(0): this mode's VertRefresh (24.0 Hz); ignoring VertRefresh
(WW) Jan 16 14:31:36 NVIDIA(0): check for mode "1920x1080".

(II) Jan 16 14:31:36 NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
(II) Jan 16 14:31:36 NVIDIA(0): may not be running or the "AcpidSocketPath" X
(II) Jan 16 14:31:36 NVIDIA(0): configuration option may not be set correctly. When the
(II) Jan 16 14:31:36 NVIDIA(0): ACPI event daemon is available, the NVIDIA X driver will
(II) Jan 16 14:31:36 NVIDIA(0): try to use it to receive ACPI event notifications. For
(II) Jan 16 14:31:36 NVIDIA(0): details, please see the "ConnectToAcpid" and
(II) Jan 16 14:31:36 NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
(II) Jan 16 14:31:36 NVIDIA(0): Config Options in the README.
(II) Jan 16 14:31:36 NVIDIA(0): Setting mode
(II) Jan 16 14:31:36 NVIDIA(0): "DFP-0:1280x1024+0+0,DFP-1:nvidia-auto-select+0+0"

If you need the complete bug report, just ask. But it's long.

Here's xorg,conf:

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"

Section "ServerFlags"
Option "AIGLX" "on"

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ViewSonic VX922"
HorizSync 30.0 - 82.0
VertRefresh 50.0 - 75.0
Option "DPMS"

Section "Device"
Identifier "Videocard0"
Driver "nvidia"

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9400 GT"

Section "Screen"
Identifier "Default Screen"
Device "Videocard0"
Monitor "Monitor0"
Option "AddARGBGLXVisuals" "True"
# Option "ConstantFrameRateHint" "True"
Option "TwinView" "True"
Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
SubSection "Display"
Modes "nvidia-auto-select"

Section "Screen"

# Removed Option "TwinViewXineramaInfoOrder" "DFP-0"
# Removed Option "metamodes" "DFP-0: 1280x1024_75 +0+0, DFP-1: nvidia-auto-select +0+0; DFP-0: nvidia-auto-select +0+0, DFP-1:
nvidia-auto-select +0+0"
# Removed Option "TwinViewXineramaInfoOrder" "DFP-1"
# Removed Option "metamodes" "DFP-0: 1280x960 +0+0, DFP-1: nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP-0: 1280x1024 +0+0, DFP-1: nvidia-auto-select +0+0"
# Removed Option "metamodes" "DFP-0: 1280x1024 +0+0, DFP-1: 1360x768 +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-0"
Option "metamodes" "DFP-0: 1280x1024 +0+0, DFP-1: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24

Section "Extensions"
Option "Composite" "Enable"

I've Googled a bit but too many different suggestions are made. I also tried things that didn't work. I hope things have settled down and you can come up with something more definitive.

Don't fear overexplaining: I know nothing in the matter.
1 answer Last reply
More about problem 9400gt fedora twinview
  1. Sorry. This doesn't belong in the ATI section.
Ask a new question

Read More

Radeon TV Monitors Nvidia Graphics