Sign in with
Sign up | Sign in
Your question
Closed

Enabled Optimized Defaults now Intel Raid Manager lists no raid array

Last response: in Storage
Share
January 22, 2012 11:46:10 PM

Hello everyone,

How do I get my raid array back after loading optimized defaults in the bios?

I mistakenly 'loaded optimized defaults' on my ASUS p8p67pro which resulted in Intel's Raid manager that loads before the OS listing no longer listing my Raid 1 array (each disk is listed, but says 'non raid disk'). The bios still shows SATA in RAID mode, but I can no longer boot to the OS (I get a blinking cursor on a black screen).

I setup my RAID 1 array in windows using Intel's RAID software. The problem is that I cannot enter windows to 'turn back on' or rebuild the array. If I use Intel's Raid tool that appears before the OS loads, it informs me that all data on all disks will be erased if I were to create a RAID array.

Is there something simple I am missing here? I understand that each time you update your bios that you need to reload the optimized defaults, but if you do then how do you re-enable your raid array so that you can us it to boot your OS?

I tried switching to AHCP to attempt to load the OS off of one of the disks, but neither will boot windows (same blinking cursor on the black screen...windows doesn't even start to load). I tried to leave it on RAID and use the 64 bit Win 7 Ultimate disk to repair...but it tells me that the version of the repair tool on the DVD does not match the version of windows on the hard drive).

ASUS P8P67 PRO (latest bios version as of 01/22/2012)
64bit Win 7 Ultimate
i5 2500k
8 Gb RAM
2 Samgung 1 TB 7200 RPM drives (that were mirrored in Raid 1 before 'loading optimized defaults')

a b å Intel
a c 82 G Storage
January 23, 2012 1:01:21 AM

Have you tried pressing Ctrl+i at POST to enter the Intel RAID option?
Score
0
January 23, 2012 1:16:04 AM

have, but hitting Ctrl-I at boot and getting into the Intel RAID options doesn't show my created RAID 1 array and each disk is now listed as a non-RAID disk. The only option I seem to have there is to create a new RAID array which informs me that the data on all disks will be erased, which I can't do.

If there is not an easy fix, the only thing I can think to do is disconnect one of my two identical drives (that were previously mirrored in RAID 1) and reinstall the OS on that drive, then so long as when I plug in the second drive all my folders/data appears I could copy over all my data to this newly installed OS drive, then use the Intel software in windows to create a new RAID 1 array by migrating the data over to the second drive.
Score
0
Related resources
a b å Intel
a c 82 G Storage
January 23, 2012 1:59:09 AM

After flashing the BIOS and loading optimized defaults, what else did you do? The RAID info is stored on the hard disks and Intel Matrix Storage should recognize members of the array unless something destroyed the required info. I've moved a RAID 1 toa different system and it was detected. Even if the array is broken, you should be able to boot from one of the hard disks and then reconstruct the RAID 1. Is the boot disk set to a RAID or a hard disk?
Score
0
January 23, 2012 2:22:25 AM

Thanks for the replies!!!

Here I did not actually flash the bios. I went into the bios and choose 'load optimized defaults', then saved bios settings and upon reboot the bios loaded and the Intel raid notification showed up but all disks were labeled as non-raid (and the raid set was missing above), then the ASUS bios screen passes and I get a black screen with a blinking cursor.

The boot disk is set as the name of the 'raid 1 disk' which I named Samsung even though there are two identical disks that made up the raid 1 array. So now even though the Intel raid info during boot indicates no raid has been created, the bios only lists one Samsung disk even though there are two plugged in. That seems to indicate that the bios still sees the two Samsung disks as one (raid info stored on the disk?).

I have tried to move the plug to for one of the Samsung drives to the Marvel controller while unplugging the other, but I get the same black screen with a blinking cursor. I tried just one Samsung drive plugged into the Intel controller while unplugging the other, but I get the same. I tried plugging both Samsung drives into the Marvell controller, but I get the same.

I am new to RAIDs, but what I really don't understand is what is the point of RAID 1 protection (other than a mechanical drive failure) if you can say reset your bios settings to default and totally loose access to both and/or either of the mirrored drives?


----------------------------

Update: Although I tried previously to set the priority of the Windows Boot Manager before any drives in the bios and it didn't boot, I just forced it to boot to the Windows Boot Manager and the OS loaded to the desktop. I found the two drives listed, one as system. The Intel Raid software in windows shows the two drives, but not in a RAID array. So at this point I wonder what to do next:

1. Should I just use the Windows Boot Manager as my boot disk until I decide to create the new RAID array?

2. Will a new migration take the 15 hours or so that it took the first time even though the two disks currently have identical data on them?
Score
0

Best solution

a b å Intel
a c 82 G Storage
January 23, 2012 11:01:19 AM


Section Configuring computer from RAID Ready to RAID 1 should apply to your configuration: http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01...

The boot drive should be identified as the first member of the RAID, etc. Unfortunately a rebuild will be performed.

I presume that you backed up the system just in case something goes wrong? A You probably ran into issues because you didn't reconfigure the RAID 1 in the BIOS before booting the system.
Share
February 7, 2012 6:36:16 PM

I did have a backup because after loading the optimized defaults in the bios, although the RAID array (raid 1) was deleted...I ended up with 2 drives with identical data to start with. From this point I decided instead of re-creating the RAID 1 array (which would involve the long (~10 hours) migration from one disk to the other, that I would buy a SSD as my OS drive and use a backup software to perform an incremental backup of all of my data from one of the identical drives to the other.

Long story short, if you load optimized defaults make sure you have a backup first...then make sure you select Windows Boot Manager instead of the two (or more) drives listed in your boot order so that you can boot off of one of the drives that was previously in RAID (unplug the others to make the OS set it as the System drive) and if you want to stay with RAID be ready to fully rebuild your RAID 1 array (through a long migration from one drive (that has the identical data on it) to the other drive.
Score
0
February 7, 2012 6:36:45 PM

Best answer selected by globe808080.
Score
0
February 8, 2012 5:29:47 PM

This topic has been closed by Mousemonkey
Score
0
!