Sign in with
Sign up | Sign in
Your question
Solved

RAID 0 doesn't show up in Windows 7 Disk Management

Last response: in Motherboards
Share
August 26, 2010 3:58:12 AM

I just built a new system with a GA-X58A-UD3R and I was hoping to have the following disk setup:

- 256GB SSD - drive C (works)
- 2x1tb WD Caviar Green in RAID 0 - drive E (Problem)
- 2TB Seagate - backup drive

Basically my boot partition is on the SSD connected via the Marvell SATA3 controller, my day to day large media stuff would be held on the RAID 0 drives (which are attached on the Intel controller) and the 2TB drive would act as a backup for the RAID 0 drives, also attached to the Intel controller.

I had this working yesterday, and then this morning when I booted into Windows the RAID 0 drives had lost their "RAID-ness", so I had no E drive. I set the 2TB as the E drive, rebooted, discovered that the Intel controller showed the RAID 0 volume status as "Failed", and then re-configured the two drives as RAID again. This seems fine at the controller level, but when I boot into windows, I do not see my 1TB drives. I tried making them separate drives again, but the only way they seem to show up now is if I use AHCI mode for the Intel controller. The Seagate, which is attached to the same controller, continues to show up in Windows 7 Disk Management.

Any ideas? Is there anything obvious I've missed in terms of resetting system state?

Best solution

a c 716 V Motherboard
August 26, 2010 5:05:08 AM

There are a lot of GA-X58A-UD3R (rev 2) MOBOs that seem to have this problem with their Intel RAID (1 or 0) {meaning there's no real fix}. In addition, I am pretty certain that the WD Caviar Green lack TLER and don't fully support RAID; WD unlike Hitachi, Seagate, etc decided to not include TLER on their consumer HDDs.

As far as a "solution" - 1. Dedicated RAID controller, 2. RAID off the GIGABYTE SATA2, 3. Different MOBO, or 4. "maybe" use TLER HDDs {but probably won't correct the problem}.

I can provide a number of "confirming" links, or you can Google just the same.

Q - Why not RAID 10? {you'd need to get 4 matching drives + a dedicated RAID controller}.

BTW - most MOBOs aren't very good for more than 2 HDD/SSD RAID 1 or 0 {simple RAID} regardless of specifications.
Share
August 26, 2010 9:20:22 AM

I tried the JMicron RAID, but it kind of sucks, performance is barely better than a single 2TB drive on the Intel controller. I don't particularly want to take the SSD off the SATA3 controller since it performs radically better on that controller than on any of the others. At this point I'm happier having two 1TB backup drives if the Intel controller's not going to do what I need.

The reason I'm using the setup I am is that I don't actually need real-time redundancy, just a reasonable failsafe in case one drive crashes. I have a large collection of purchased digital media. RAID 0 was strictly for day-to-day performance boost; we use Dell Precision workstations with a simple RAID 0 setup at work and the performance difference is quite noticeable. I don't need anything more complex than that, the backup drive is just a failsafe because it finally occurred to me that if I was going to be buying huge amounts of media in digital form I should really back them up.

Admittedly I could rely on optical media for backups, but for now a hard disk based backup scheme suits my needs better.
m
0
l
Related resources
a c 716 V Motherboard
August 26, 2010 3:59:36 PM

liquiddark said:
I tried the JMicron RAID, but it kind of sucks, performance is barely better than a single 2TB drive on the Intel controller. I don't particularly want to take the SSD off the SATA3 controller since it performs radically better on that controller than on any of the others.


Sorry if it seemed I was referring to ALL drives - I was not, I was only referring to the RAID drives and there's no way I would recommend that you pull the SSD off the SATA3 especially "if" you're running something like a Crucial RealSSD C300 256GB SATA3.

Unfortunately, the GA-X58A-UD3R has a proven progressive problem with the Intel SATA2 on-board RAID controller, and I am pretty confident that no matter what you do {BIOS, drivers, etc} it is not going to fix that problem. Therefore, my recommendation is to exchange your MOBO with either the GA-X58A-UD5 (rev. 2.0) or Asus P6X58D-E - or better; otherwise use a dedicated RAID controller.

In addition, just looking at cost 2TB ~ 2 1TB - a RAID 10 seems a better option and requires little "management" plus it's fast + reliable vs your RAID 0 1TB + periodic backup on a 2 TB. I "get" where you're coming from with your configuration. I also know how frustrating it might be finding out problems after the fact...

GA-X58A-UD3R - http://www.tomshardware.com/forum/276715-30-x58a-ud3r-r...
Ports - http://www.tomshardware.com/forum/278015-30-mobo-ideal-...

"If" I were to build a similar system:
MOBO - ASUS P6X58D-E {similar cost/lacks eSATA}, GA-X58A-UD5 (rev. 2.0), or Asus P6X58D Premium
SSD - (keep)
HDD - 4 1 TB HDD w/TLER in RAID 10 - WD {Enterprise category}/ WD1003FBYX 64MB, WD1002FBYS 32MB, or Hitachi or Seagate {which don't play the disable the TLER game}.
HDD Alternative - Hybrid HDD {incorporates small SSD + HDD}
RAID - if running RAID 10 then purchase an Adaptec RAID Controller. RAID 0 or 1 should run okay off "most" MOBOs just not the GA-X58A-UD3R.

Simplest fix is either a new MOBO or dedicated RAID controller.
m
0
l
August 27, 2010 7:14:26 AM

Yeah, I really should have researched this area of the system more thoroughly. For the moment I'm just doing partial backups to the two 1TB drives. It's more maintenance, but it's ok for now. I'll know for next time, though.
m
0
l
a c 716 V Motherboard
August 27, 2010 3:09:48 PM

The sad reality is "on paper" the GA-X58A-UD3R "should be" a great MOBO, and the reviews are very good with one exception - they didn't test the RAID. Ideally the smart idea you had of combining Speed + Reality {SSD + HDD (RAID/back-up)} is becoming closer to the "norm" and should be tested by reviewers. RAID 0, 1, & 10 require very little computations and MOBOs shouldn't have a hard time getting them to work properly.

Q - What is the status of your build? Are you running the HDD on the GSATA3 or GSATA2 ports?

In addition, for a second eye I would recommend you post your issue on http://forums.tweaktown.com/ - ask for Lsdmeasap he's the GA guru and already knows about the GA-X58A-UD3R issues.

Good RAID video - http://www.youtube.com/user/NCIXcom#p/u/0/TuwjadbtUCY

Good Luck!
m
0
l
September 3, 2010 2:49:08 AM

Best answer selected by liquiddark.
m
0
l
September 3, 2010 2:55:26 AM

I hooked the two 1TBs up to the ICH controller as single drives along with the 2TB drive and did a partial backup to each 1tb drive. only thing on the GSATA3 is the C300. It's plenty fast, but I need to get a software backup solution configured at some point. Probably should just get another 2TB drive and do a 1:1 backup, but seems like an awful waste of money when I've already got the 3 1TB drives hanging around here, so for the moment I'm gonna go with the slightly higher maintenance approach.

Appreciate all your help on this, and you're right, this is the scenario that even half-assed enthusiasts such as myself are targeting nowadays, seems like it's time to include a detailed scenario with mobo reviews.

It's funny how many people seem to have this setup working with the higher numbered boards, particularly the UD7 and UD9.
m
0
l
a c 716 V Motherboard
September 3, 2010 3:12:17 PM

No, you're idea was good one. Most folks don't know about RAID 10 and seldom use it in a personal rig. If there's any way possible to to exchange the 2TB HDD for 2 1TB, and purchase a simple RAID card then I'd go the RAID 10 {4x1TB}.

Regarding the Review yeah they should run SSD {Apps + OS} + RAID {Data}!!! Having small SSDs plus HDD is defiantly where things are going - the new HHD are trying to address this trend.

I wish you the Best & Good Luck!
m
0
l
!