Asrock 890fx deluxe3 sound problems

I've got an asrock 890fx deluxe3 and i am experiancing sound stuttering and static when playing audio. Board has a VIA VT2020 audio codec. This appears to be limited to win xp pro 32-bit, as I have not noticed the problem with win7 64-bit. :fou: Is anyone else having a similar problem? If so have you been able to correct it? I have used the drivers from both the download on asrocks site, and the support dvd, nada on both. Is it possible for me to use the drivers from the ASUS crosshair IV mobo, since it also uses the same via codec?

Any help would be appreciated.
1 answer Last reply
More about asrock 890fx deluxe3 sound problems
  1. sl83r said:
    I've got an asrock 890fx deluxe3 and i am experiancing sound stuttering and static when playing audio. Board has a VIA VT2020 audio codec. This appears to be limited to win xp pro 32-bit, as I have not noticed the problem with win7 64-bit. :fou: Is anyone else having a similar problem? If so have you been able to correct it? I have used the drivers from both the download on asrocks site, and the support dvd, nada on both. Is it possible for me to use the drivers from the ASUS crosshair IV mobo, since it also uses the same via codec?

    Any help would be appreciated.


    I had the same probs also, I ended up using the Crosshair IV drivers in xp, although it DID take a few tries(install,uninstall,re-install again) to get them to fully work correctly.
Ask a new question

Read More

Motherboards Audio ASrock