My Passport Essential SE 1GB not working at all

Hi, i just bought a Western Digital My Passport Essential SE 1TB and i keep getting a "usb over current error" when i plug it into my dell desktop.
now from what i could gather i get this error because my usb 2.0 ports aren't providing enough power, but the thing is, my ports allow 500mA of power to go through them, which is enough to power the drive, so my question is, why isn't my hard drive working?
before you ask, yes i've tried every port on my computer, and i've also unplugged every other device and tried it and got nothing, no movement on the drive or anything. i am also using the cord that came with the product. its not showing up in device manager or disk management or anywhere else. when i plug it into a port the whole port stops functioning.

Please answer!

*Edit - 1TB, not GB

Thanks!
3 answers Last reply
More about passport essential working
  1. After checking around, it seems most times this is caused by a damaged usb port.

    http://www.whoho.com/2011/03/usb-device-over-current-status-detected.html

    http://www.youtube.com/watch?v=9V_mCvoD8Sg
  2. well i tried it on all 9 of my usb ports, including the one my keyboard is using to type this.
  3. Y-cable
Ask a new question

Read More

Hard Drives Power Storage