Sign in with
Sign up | Sign in
Your question
Solved

Overclocking i5 2500K

Last response: in Overclocking
Share
September 24, 2012 1:56:05 PM

Hi

I need some help with overclocking my i5 2500K

System spec
PSU 750W Corsair Tx
CPU i5200k
MBoard Asus Z68 M Pro
212 Evo cooler
MSI GTX 570
8 Gig Ram 1600Mhz

My problem is this, in my bios The max i can set the multiplier is 33 @ 100Mhz ( 3.3 Ghz) which is the standard for the CPU

Do i need to update my bios to have the option to increase the CPU multiplier above 33

Please note, that my Mboard is the M Pro (Mini ATX) and NOT the Deluxe Pro

Any suggestions would be appreciated

More about : overclocking 2500k

a b K Overclocking
September 24, 2012 3:57:23 PM

Do you have AI Suite II installed? It should have some automatic overclock settings. (just push the turbo button) AI Suite also has the Asus bios update controls.

Edit: I recognize that doing from the BIOS is preferred by some - just recommending you use the easy overclock mode first to make sure its all working the way it should.
m
0
l

Best solution

October 5, 2012 6:58:01 AM

somewhat agree with deadlock. Due to turbo mode, overclocking the sandybridge cpus are somewhat more complex. Nonetheless 33x multiplier is plenty, just start raising your FSB and youll get higher clock. strongly recommend a guide before you do this yourself.
Share
Related resources
a b V Motherboard
a c 242 K Overclocking
October 5, 2012 12:52:36 PM

bigbang said:
just start raising your FSB and youll get higher clock

no raise FSB, keep it at 100
m
0
l
October 12, 2012 5:51:22 PM

Thanks for the input

33X is plenty, but i was just wondering for future, if ever needed how i would go bout overclocking. I guess the FSB route is my best option then

better get reading then

Im so bummed though. thought i would just be able to up the multiplier to 38

Thanks for the help guys
m
0
l
October 12, 2012 5:51:33 PM

Best answer selected by energy52.
m
0
l
October 13, 2012 8:29:40 AM

again turbo mode automatically increases your multiplier by 5x (i think) during computing intensive tasks. You can disable or override this but I am not entirely certain how. I have seen it before using intel extreme overclocking package.
m
0
l
!