Is it a PSU or game problem ?

Hey guys :-)

my pc specifications are :
Intel C2D E6420 Processor ,
Intel DG965RY MOBO ,
Sapphire Radeon HD 4670 1GB DDR3 ,
And not well known 400W PSU brand

I can play all modern games like MW2 , NFS SHIFT , RESIDENT EVIL 5 perfect at max setting without any crash ,
but when i start to play ASSASSIN CREED 1 it crashes after 15 min of playing and don't know why { the system reboots or it close immediatly } ...

My question is it a PSU problem or the game it self isn't ok ?


*NOTE : I had tried that game on my Nvidia Geforce 7300Le and the same problem
9 answers Last reply
More about game problem
  1. Do you have the newest patch for the game?

    Try reinstalling the Game.

    Also, run HWMonitor ( http://www.cpuid.com/hwmonitor.php ) and then start the game so you can see the maximum temperatures reached by components like the CPU and GPU.

    And the game does work, at least on my system.
  2. I don't have the newest patch :-(

    about the temperatures :
    GPU at full load 55~ c
    CPU at full load 45~50 c
    everything is good up

    btw how can i get the latest patch ?
  3. http://www.ubi.com/US/Downloads/Info.aspx?dlId=2507

    It does say it fixed a rare crash. I wouldn't expect much from this, but worth a try for sure.
  4. And about the RAM :
    I have 3GB DDR2 AT 664 MHz
  5. With a 4670 that should be fine, I would think, unless it is REALLY a cheapo PSU. But I would assume you would experience this in most games. I'd reinstall or check new game patches. Also, update video drivers. Alot of times ATI will patch drivers for certain games.
  6. Ok , i tried to install the new CCC And it's drivers from sapphire site but after that the CCC hadn't work and don't know why , so i installed the old drivers which comes with the graphic card ...............

    What you think?
  7. ^I'd install the drivers from the ATI site. Usually the ones on the manufacture site aren't the most up to date.
  8. Or just repackaged versions of the ATI ones, which adds one more chance for error.
  9. Ok , i have another problem which it's when i want to install the drivers from the CD using the autorun it gives me this message :

    Error extracting support files :
    The system cannot find path specified

    so i managed to install the drivers using the device manager and CCC manually ..

    Anyone have any solution for this?
Ask a new question

Read More

Graphics Cards Games Intel Graphics