Catalyst will not run

After trying to install the catalyst control center, i get the MOM.implementation error. Apparently this is a big problem. After just spending 300 dollars on a gpu, you would think the software that comes with it would be up to date. Anyway I tried reinstalling the drivers, reinstalling the .net framework, and using driver sweeper to aid me in doing so.

When partially through installing the catalyst software from the disk and the drivers, my PC will spontaneously reboot. This happens every time. I just cant get through the install. Has anyone found a fix for this yet? BTW im running XP.
7 answers Last reply
More about catalyst
  1. It should not be a problem!!Try the latest catalyst drivers for xp!!The driver discs bundled with your gpu might be quite old!!
  2. Is this a new install/build? Would it be possible to do a full reformat, or will you lose too much data/programs? Also, what card did you get?
  3. I cant believe i forgot to list the gpu. Its a sapphire ATI 5850. Rather new afik. Anyway it was a brand new build. Latest drivers also didnt work. Format; could have worked, i guess technically it did, since i did format during the upgrade to windows 7 ultimate. The problem was completely solved by using windows 7. It was really my last resort.
  4. Well, good to hear you got it fixed. I have a Sapphire 5850 and Win7 64 Enterprise (aka Ultimate) and it works great too. Normally if I get a weird software issue, I just do a full reformat (and most of the time that works).
  5. I guess the good news to that upgrade is now you can utilize the DX11 features. I hope you enjoy win7 too.
  6. It works well, though it certainly has some quirks. if you run into any user account issues (can't log in) or game/mod install issues (crashes, etc.) let me know, as I have encountered and fixed a decent number so I might be able to help.
  7. I'm running XP Pro SP3 with the NET.Framework (all) additions.

    Installed CCC/driver as best I could (error messages and all).

    Then, I copied cli.implementaion.dll and mom.implentation.dll to C:\, to the folder the CCC/driver (downloaded) was in, and to C:\Windows\System32.

    Un-installed CCC with ATI's install manager thru Add/Remove Programs.

    Ran the downloaded install/setup again.

    CCC and driver now work perfectly.
Ask a new question

Read More

Radeon Drivers Catalyst Software Graphics